summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-08-21 16:09:48 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-08-23 01:21:27 -0400
commit69acb4d8b2d72f4405e58386b6c9b35608a21d51 (patch)
tree2b91c940d28ef770f6843fe353dc48d5820729cd /gnome-extra
parentgnome-extra/nemo: drop 6.2.6 (diff)
downloadgentoo-69acb4d8b2d72f4405e58386b6c9b35608a21d51.tar.gz
gentoo-69acb4d8b2d72f4405e58386b6c9b35608a21d51.tar.bz2
gentoo-69acb4d8b2d72f4405e58386b6c9b35608a21d51.zip
gnome-extra/nemo: avoid automagic dependency on gtk+[X]; don't restrict wayland
Currently, one is forced to compile nemo and gtk with the same value of USE=wayland which makes it difficult to provide generically reusable binaries. It is better than automagically depending on wayland and then lacking it, but not ideal. Preferable would be for nemo[wayland] to require gtk+[wayland] but when built without wayland support, to not care whether gtk itself is. We now support a mechanism for packages to opt out of gtk providing the API, for use by packages that don't provide a `-D wayland=true` but autodetect whether gtk was built with it. Use that mechanism. Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/nemo/nemo-6.2.8.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnome-extra/nemo/nemo-6.2.8.ebuild b/gnome-extra/nemo/nemo-6.2.8.ebuild
index 950d7f610adc..d2f1b546ca6d 100644
--- a/gnome-extra/nemo/nemo-6.2.8.ebuild
+++ b/gnome-extra/nemo/nemo-6.2.8.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..13} )
-inherit meson gnome2-utils python-single-r1 readme.gentoo-r1 virtualx xdg
+inherit meson flag-o-matic gnome2-utils python-single-r1 readme.gentoo-r1 virtualx xdg
DESCRIPTION="A file manager for Cinnamon, forked from Nautilus"
HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/nemo"
@@ -31,7 +31,7 @@ COMMON_DEPEND="
gnome-extra/libgsf:=
x11-libs/cairo
x11-libs/gdk-pixbuf:2
- >=x11-libs/gtk+-3.10.0:3[introspection,wayland=]
+ >=x11-libs/gtk+-3.24.41-r1:3[introspection,wayland?,X]
x11-libs/libX11
>=x11-libs/pango-1.40.0
>=x11-libs/xapp-2.8.4[introspection]
@@ -112,6 +112,9 @@ src_prepare() {
}
src_configure() {
+ # defang automagic dependencies
+ use wayland || append-cflags -DGENTOO_GTK_HIDE_WAYLAND
+
local emesonargs=(
$(meson_use exif)
$(meson_use xmp)