summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/gtklife
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/gtklife')
-rw-r--r--games-misc/gtklife/Manifest1
-rw-r--r--games-misc/gtklife/files/gtklife-5.1-link.patch20
-rw-r--r--games-misc/gtklife/gtklife-5.1.ebuild45
-rw-r--r--games-misc/gtklife/metadata.xml5
4 files changed, 71 insertions, 0 deletions
diff --git a/games-misc/gtklife/Manifest b/games-misc/gtklife/Manifest
new file mode 100644
index 000000000000..d60e538a5304
--- /dev/null
+++ b/games-misc/gtklife/Manifest
@@ -0,0 +1 @@
+DIST gtklife-5.1.tar.gz 809542 SHA256 fcf5a6515595d1822291fd6da4fec93dcfb5162cfce48445686ba73ab4a98191 SHA512 b80a2f0fc41583c2905e84e00baf689870c22262a55af25dfc2fe9e914d214f9c01b6800125e68516b63067005d25338ee7edf0c63ee37327479411693840025 WHIRLPOOL 6553956c570bd83d4237c02055d77a82944f30c9a6760c8dd6bbaafbca97633589c94ede839ea7abb4c2e3537856c6733de4fc1f369c8bd56e40361bc6469d27
diff --git a/games-misc/gtklife/files/gtklife-5.1-link.patch b/games-misc/gtklife/files/gtklife-5.1-link.patch
new file mode 100644
index 000000000000..8aae429def1c
--- /dev/null
+++ b/games-misc/gtklife/files/gtklife-5.1-link.patch
@@ -0,0 +1,20 @@
+--- Makefile.in.old 2014-07-24 21:25:09.072431615 +0200
++++ Makefile.in 2014-07-24 21:26:34.898037740 +0200
+@@ -22,7 +22,7 @@
+ # Preprocessor and linking flags
+
+ CPPFLAGS:=$(CPPFLAGS) $(GTK_CFLAGS) -DVERSION=\"$(VERSION)\" -DDATADIR=\"$(pkgdatadir)\" -DDOCDIR=\"$(docdir)\"
+-LDFLAGS:=$(LDFLAGS) $(GTK_LIBS)
++LDLIBS:=$(GTK_LIBS) -lX11
+
+ # Object files
+
+@@ -51,7 +51,7 @@
+ $(INSTALL_DATA) doc/* $(docdir)
+
+ gtklife: $(OBJS)
+- $(CC) -o gtklife $(OBJS) $(LDFLAGS)
++ $(CC) -o gtklife $(OBJS) $(LDFLAGS) $(LDLIBS)
+
+ create_lookup: $(CL_OBJS)
+ $(CC) -o create_lookup $(CL_OBJS)
diff --git a/games-misc/gtklife/gtklife-5.1.ebuild b/games-misc/gtklife/gtklife-5.1.ebuild
new file mode 100644
index 000000000000..08cdc4311d75
--- /dev/null
+++ b/games-misc/gtklife/gtklife-5.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils games
+
+DESCRIPTION="A Conway's Life simulator for Unix"
+HOMEPAGE="http://ironphoenix.org/tril/gtklife/"
+SRC_URI="http://ironphoenix.org/tril/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ~ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ dev-libs/glib:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-link.patch
+}
+
+src_configure() {
+ egamesconf \
+ --with-gtk2 \
+ --with-docdir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ dogamesbin ${PN}
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r graphics patterns
+
+ newicon icon_48x48.png ${PN}.png
+ make_desktop_entry ${PN} GtkLife
+
+ dohtml doc/*
+ dodoc AUTHORS README NEWS
+ prepgamesdirs
+}
diff --git a/games-misc/gtklife/metadata.xml b/games-misc/gtklife/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-misc/gtklife/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>