summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2019-02-12 10:12:56 +0800
committerYixun Lan <dlan@gentoo.org>2019-02-12 10:16:00 +0800
commit6ff43ececc8d5de64218319922d6cf462a69b7ed (patch)
tree6ef84c58fd658bac1670fb801bec6113deeb8ed1 /dev-util/vmtouch/vmtouch-1.3.1.ebuild
parentapp-backup/snapper: drop old (diff)
downloadgentoo-6ff43ececc8d5de64218319922d6cf462a69b7ed.tar.gz
gentoo-6ff43ececc8d5de64218319922d6cf462a69b7ed.tar.bz2
gentoo-6ff43ececc8d5de64218319922d6cf462a69b7ed.zip
dev-util/vmtouch: version bump 1.3.1
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-util/vmtouch/vmtouch-1.3.1.ebuild')
-rw-r--r--dev-util/vmtouch/vmtouch-1.3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/vmtouch/vmtouch-1.3.1.ebuild b/dev-util/vmtouch/vmtouch-1.3.1.ebuild
new file mode 100644
index 000000000000..ce4da1de358a
--- /dev/null
+++ b/dev-util/vmtouch/vmtouch-1.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Virtual Memory Toucher, portable file system cache diagnostics and control"
+HOMEPAGE="http://hoytech.com/vmtouch/"
+SRC_URI="https://github.com/hoytech/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ local my_prefix="${ED}/usr"
+ emake PREFIX="${my_prefix}" MANDIR="${my_prefix}/share/man/man8" install
+ dodoc CHANGES README.md TODO
+}