summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-11-07 17:36:51 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2023-11-07 17:37:22 -0600
commit4d6d54a2f2635e0600d5803baa2349780ae7879d (patch)
treed0c888ca1bd069cc26c1e4c93609aec7e92f681a /dev-ruby
parentapp-admin/puppetdb: add 8.2.0 (diff)
downloadgentoo-4d6d54a2f2635e0600d5803baa2349780ae7879d.tar.gz
gentoo-4d6d54a2f2635e0600d5803baa2349780ae7879d.tar.bz2
gentoo-4d6d54a2f2635e0600d5803baa2349780ae7879d.zip
dev-ruby/puppetdb-termini: add 8.2.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-8.2.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 29052360b40e..bf4a249cc0ea 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,2 +1,3 @@
DIST puppetdb-termini_7.13.0-1bullseye_all.deb 22548 BLAKE2B 535a3f846a7a10dcfaec4447ae852c6c4d870a573169f84e31f61c361164caea989f911df2d18e183c391dd0130a10b9422057eecaab304bebbb022f78e22a21 SHA512 3c8e440bfc55579d0c9a03ecae516d4cef49512ad9fdd6fceef37618c163ecac6d77a2b17b6cbb7131ceb3787904486bb78eef84a36a5f76672918db6d30db86
DIST puppetdb-termini_8.1.0-1focal_all.deb 21764 BLAKE2B b45c0fd944422511d2419a1e27a92f348415369ffcd27a53ad8244b2fb993bc735f291b5ae4277706b204c73402c110245a1d750adaaa4bfb94f5133adb4812d SHA512 51cf64d4e08275072a5fbfb7df273574acfe57c228d13d55a96975e26ab0eedd02280ba5dc08441f2e691cdeef10ae771ce26f14f05b2dfeaed4945041687a15
+DIST puppetdb-termini_8.2.0-1focal_all.deb 21850 BLAKE2B 3f2d35a24c3884fdc985cd22e2c27d159dbea80272f5d1510634fc3b93079fd33e2b4f19963e2e122eb25829aa118ac13a84d6838c73ccb54305afc7876f8fc6 SHA512 ebf05f85d4bd455498a40b0210a6fc0cbfed4d0991d5a3d5780eb1b99a2f93f64407d6465d010c53ff55a0a3fcfab6f411c851d95a9e028945634644baef5163
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-8.2.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-8.2.0.ebuild
new file mode 100644
index 000000000000..dfbabaa8b2cd
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-8.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="https://puppet.com/docs/puppetdb/latest/index.html"
+SRC_URI="http://apt.puppetlabs.com/pool/focal/puppet8/${PN:0:1}/${PN}/${PN}_${PV}-1focal_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}