summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/gpgme
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/gpgme')
-rw-r--r--dev-ruby/gpgme/Manifest2
-rw-r--r--dev-ruby/gpgme/gpgme-2.0.8.ebuild46
-rw-r--r--dev-ruby/gpgme/gpgme-2.0.9.ebuild55
-rw-r--r--dev-ruby/gpgme/metadata.xml9
4 files changed, 112 insertions, 0 deletions
diff --git a/dev-ruby/gpgme/Manifest b/dev-ruby/gpgme/Manifest
new file mode 100644
index 000000000000..d6413146f05f
--- /dev/null
+++ b/dev-ruby/gpgme/Manifest
@@ -0,0 +1,2 @@
+DIST gpgme-2.0.8.gem 2221056 SHA256 b54f47c3c932f4331e1c8d4ac971fe203ac030be38788b23fd5d05aa631dd0ab SHA512 9ff616d2c11af05aaa69fa132040c6268f01d05a8444297814326e0cd57dcf21fcc5489cc4e1fd3d40ad7652fa06abbb37caf0b69664e38489ed6939b96dfe7f WHIRLPOOL e085fbf9d806fbdcbaf91f6acf008de6b6ebdb6764ec07acb7e948f19535d92f72a61f76520e7ed83d11f55e9a87f798149c11061e58ebd388c244394e93570b
+DIST ruby-gpgme-2.0.9.tar.gz 2359780 SHA256 110a983c5b77c3252ae500b5b5fb0aa1b2bfef84f14bb82b68521fc51862397c SHA512 4916ea39b1db43151b07bba570fa469b36c7cb1a346166181e40a61dc877872c3a264d5ed7cb9a582cc700d561d4e30784a72985dc6ca8d5a55064b3709559f5 WHIRLPOOL 4ba59603367c7a419149d0fe22bc6a63c979bfd064f0bd177287ff11973f9e84c7e0364f00697143caae477d0eecfed854deb8e60fa4b976ef6e4e8b79335a9d
diff --git a/dev-ruby/gpgme/gpgme-2.0.8.ebuild b/dev-ruby/gpgme/gpgme-2.0.8.ebuild
new file mode 100644
index 000000000000..e76b97a1a76e
--- /dev/null
+++ b/dev-ruby/gpgme/gpgme-2.0.8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-ng ruby-fakegem flag-o-matic
+
+DESCRIPTION="Ruby language binding for GnuPG Made Easy"
+HOMEPAGE="https://github.com/ueno/ruby-gpgme"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND+=">=app-crypt/gpgme-1.1.3"
+RDEPEND+=">=app-crypt/gpgme-1.1.3"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/\(coverall\|bundler\|ruby-debug\|byebug\)/I s:^:#:' test/test_helper.rb || die
+
+ # Remove failing tests for now. This package was added without
+ # running any tests :-(
+ rm test/{ctx,crypto,key}_test.rb || die
+}
+
+each_ruby_configure() {
+ append-flags -fPIC
+ export RUBY_GPGME_USE_SYSTEM_LIBRARIES=1
+ ${RUBY} -C ext "${S}/ext/gpgme/extconf.rb" || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -C ext archflag="${LDFLAGS}" || die "emake failed"
+ cp -f "${S}/ext/gpgme_n.so" "${S}/lib" || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/gpgme/gpgme-2.0.9.ebuild b/dev-ruby/gpgme/gpgme-2.0.9.ebuild
new file mode 100644
index 000000000000..578a8a07a54c
--- /dev/null
+++ b/dev-ruby/gpgme/gpgme-2.0.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="NEWS README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-ng ruby-fakegem flag-o-matic
+
+DESCRIPTION="Ruby language binding for GnuPG Made Easy"
+HOMEPAGE="https://github.com/ueno/ruby-gpgme"
+SRC_URI="https://github.com/ueno/ruby-gpgme/archive/${PV}.tar.gz -> ruby-${P}.tar.gz"
+RUBY_S="ruby-${P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND+=">=app-crypt/gpgme-1.1.3"
+RDEPEND+=">=app-crypt/gpgme-1.1.3"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha:0.14 )"
+
+all_ruby_prepare() {
+ sed -i -e '/\(coverall\|bundler\|ruby-debug\|byebug\)/I s:^:#:' \
+ -e '3igem "mocha", "~> 0.14"' \
+ test/test_helper.rb || die
+
+ # Remove failing tests for now. This package was added without
+ # running any tests :-(
+ rm -f test/{ctx,crypto}_test.rb || die
+
+ sed -i -e '/portile/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_configure() {
+ append-flags -fPIC
+ export RUBY_GPGME_USE_SYSTEM_LIBRARIES=1
+ ${RUBY} -C ext "${S}/ext/gpgme/extconf.rb" || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -C ext archflag="${LDFLAGS}" || die "emake failed"
+ cp -f "${S}/ext/gpgme_n.so" "${S}/lib" || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/gpgme/metadata.xml b/dev-ruby/gpgme/metadata.xml
new file mode 100644
index 000000000000..7a8a11258786
--- /dev/null
+++ b/dev-ruby/gpgme/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sysadmin</herd>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">ueno/ruby-gpgme</remote-id>
+ </upstream>
+</pkgmetadata>