summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/aws-s3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/aws-s3')
-rw-r--r--dev-ruby/aws-s3/Manifest1
-rw-r--r--dev-ruby/aws-s3/aws-s3-0.6.3.ebuild39
-rw-r--r--dev-ruby/aws-s3/files/aws-s3-0.6.3+ruby19.patch29
-rw-r--r--dev-ruby/aws-s3/metadata.xml5
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/aws-s3/Manifest b/dev-ruby/aws-s3/Manifest
new file mode 100644
index 000000000000..4f2bfcc482a9
--- /dev/null
+++ b/dev-ruby/aws-s3/Manifest
@@ -0,0 +1 @@
+DIST aws-s3-0.6.3.gem 137216 SHA256 5ffdec2648990987a4e024fb7f3ae9e20c5d6bd692543237afa58871ec9d8246 SHA512 817d74636a1c27fbb6e5529b99da48b61ccfac4e4bb5ce3bf4e24abcf10026678a8a6b93b8b9ef1983e9eaaf7567563094a46bd5d09c6c0fea052b5f4eecd728 WHIRLPOOL 239f381939fa9b85b1c154cadf76e4d698906a64aac0a5f88ef06522dbb6031aabb187f6f104fa264bb6ead57939c78274861c3567df76f53aa64618b6663012
diff --git a/dev-ruby/aws-s3/aws-s3-0.6.3.ebuild b/dev-ruby/aws-s3/aws-s3-0.6.3.ebuild
new file mode 100644
index 000000000000..7f8de25ed1cf
--- /dev/null
+++ b/dev-ruby/aws-s3/aws-s3-0.6.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README"
+
+# there is a stupid setup.rb in the bin/ directory so do not use the
+# default.
+RUBY_FAKEGEM_BINWRAP="s3sh"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Client library for Amazon's Simple Storage Service's REST API"
+HOMEPAGE="http://amazon.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/xml-simple
+ dev-ruby/builder
+ dev-ruby/mime-types
+ virtual/ruby-ssl"
+ruby_add_bdepend "test? ( dev-ruby/flexmock )"
+
+RUBY_PATCHES=(
+ ${P}+ruby19.patch
+)
+
+each_ruby_test() {
+ ${RUBY} -I. -e "Dir['test/*_test.rb'].each {|f| require f }" || die
+}
diff --git a/dev-ruby/aws-s3/files/aws-s3-0.6.3+ruby19.patch b/dev-ruby/aws-s3/files/aws-s3-0.6.3+ruby19.patch
new file mode 100644
index 000000000000..d97f7f1ec654
--- /dev/null
+++ b/dev-ruby/aws-s3/files/aws-s3-0.6.3+ruby19.patch
@@ -0,0 +1,29 @@
+diff --git a/Rakefile b/Rakefile
+index 4d097df..a38bdbc 100644
+--- a/Rakefile
++++ b/Rakefile
+@@ -290,6 +290,7 @@ namespace :todo do
+ end
+ end if File.exists?(File.join(library_root, 'TODO'))
+
++begin
+ namespace :site do
+ require 'erb'
+ require 'rdoc/markup/simple_markup'
+@@ -330,5 +331,7 @@ namespace :site do
+ sh %(scp #{site_files.join ' '} marcel@rubyforge.org:/var/www/gforge-projects/amazon/)
+ end
+ end
++rescue LoadError
++end
+
+ task :clean => ['dist:clobber_package', 'doc:clobber_rdoc', 'test:clobber_coverage']
+diff --git a/test/extensions_test.rb b/test/extensions_test.rb
+index 1c868ee..921e6b5 100644
+--- a/test/extensions_test.rb
++++ b/test/extensions_test.rb
+@@ -1,3 +1,4 @@
++# -*- coding: utf-8 -*-
+ require File.dirname(__FILE__) + '/test_helper'
+
+ class HashExtensionsTest < Test::Unit::TestCase
diff --git a/dev-ruby/aws-s3/metadata.xml b/dev-ruby/aws-s3/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/aws-s3/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>