summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-11-02 10:40:25 +0100
committerHans de Graaff <graaff@gentoo.org>2024-11-02 10:40:40 +0100
commite7ccf34369f535cf169498ce3ed465216de707b0 (patch)
treea81dcdccec620cf430b70c8404570192ec3bd636 /dev-ruby/activesupport
parentdev-python/stripe: Stabilize 11.1.1 ALLARCHES, #942741 (diff)
downloadgentoo-e7ccf34369f535cf169498ce3ed465216de707b0.tar.gz
gentoo-e7ccf34369f535cf169498ce3ed465216de707b0.tar.bz2
gentoo-e7ccf34369f535cf169498ce3ed465216de707b0.zip
dev-ruby/activesupport: add 7.2.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/Manifest1
-rw-r--r--dev-ruby/activesupport/activesupport-7.2.2.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-ruby/activesupport/Manifest b/dev-ruby/activesupport/Manifest
index 28f9ef991b96..a566c5369e3e 100644
--- a/dev-ruby/activesupport/Manifest
+++ b/dev-ruby/activesupport/Manifest
@@ -10,3 +10,4 @@ DIST rails-7.1.5.tgz 10933914 BLAKE2B 4af6c007b3ae0b28dff6bd603ae06e516079f95e8d
DIST rails-7.2.1.1.tgz 11062191 BLAKE2B 1fbecb5a2d47168ddcfad2bb82b0ebd45f43d3e0789e60286661c912d13a83a82e6a6651b6a8c196062d616a25a3c55aa510a129cc255d8a72876f43715d5ed4 SHA512 c430cf3886983e905fe5bbd6a4b502fcd137612361aaaaee606634de38c77eb211b86b041cf64f484741133d4cbc60daa9ca93a630cc97adc6ec43be36e09ef5
DIST rails-7.2.1.2.tgz 11062632 BLAKE2B bea7bce77556b4ee8b58a7b77df5f333379af9c6d0226bf3f5033bc416e55bf0926dd72e0509ccf3eb173ffdbb2aa2fb4b4ee762b3a57d7a5de2200d4b08e6a0 SHA512 8ec9b6ab4f0898e99b9aa9bb9d741510216e3ebff695d451e5691f0d32e8cb18d40c1a7310e16cc4bb1f55f1dd88ca7242a6165190311d11b13e6e2046da63cc
DIST rails-7.2.1.tgz 11065899 BLAKE2B 7858184a6e5ed07af56566e84d9ccdacf9d37ae3cb0a60ce09f632db782b5f97b3298c1a48147c2cb94b420e8186721ca00d9eff25ecee33f03c5348923e5fa5 SHA512 3ba68311f5b15fac647047d5e2bdbf0bf088ee4bd1208f3a47064cc7bc10794bf28f94aaabf410b773c6ff90638c8f08ebb74297855a303d080ffea9e96d25ef
+DIST rails-7.2.2.tgz 11171772 BLAKE2B 1b47171ea14c437b424152f6e4dbd28eeb7a302a1aca0c769405ee948d66f6cbfcc108f7a33d506111dfc1250f2a44b7b45aeb05b3e536833953814fc8523ff4 SHA512 6d3fbde739ceacfbd424bf94b9b9bae9e910c0e72b39e2f4c8c33b270b383b2d12022738e3f1f8a6e2c0e95a4759a99343ffe2e618ecee266e458308c14c5d39
diff --git a/dev-ruby/activesupport/activesupport-7.2.2.ebuild b/dev-ruby/activesupport/activesupport-7.2.2.ebuild
new file mode 100644
index 000000000000..224d37048f84
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-7.2.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+msgpack test"
+REQUIRED_USE="test? ( msgpack )"
+
+PATCHES=( "${FILESDIR}/${PN}-7.1.1-backport-pr50097.patch" )
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ dev-ruby/base64
+ dev-ruby/bigdecimal
+ >=dev-ruby/concurrent-ruby-1.3.1:1
+ >=dev-ruby/connection_pool-2.2.5
+ dev-ruby/drb
+ >=dev-ruby/i18n-1.6:1
+ >=dev-ruby/minitest-5.1
+ >=dev-ruby/securerandom-0.3
+ >=dev-ruby/tzinfo-2.0.5:2
+ msgpack? ( >=dev-ruby/msgpack-1.7.0 )
+"
+
+# memcache-client, nokogiri, builder, and redis are not strictly needed,
+# but there are tests using this code.
+ruby_add_bdepend "test? (
+ >=dev-ruby/dalli-3.0.1
+ >=dev-ruby/nokogiri-1.8.1
+ >=dev-ruby/builder-3.1.0
+ >=dev-ruby/listen-3.3:3
+ dev-ruby/rack:3.0
+ dev-ruby/rexml
+ dev-ruby/mocha
+ >dev-ruby/minitest-5.15.0:*
+ )"
+
+all_ruby_prepare() {
+ # Set the secure permissions that tests expect.
+ chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(system_timer\|execjs\|jquery-rails\|journey\|ruby-prof\|stackprof\|benchmark-ips\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|sqlite\|websocket-client-simple\|\libxml-ruby\|bootsnap\|aws-sdk\|webmock\|capybara\|sass-rails\|selenium-webdriver\|webpacker\|webrick\|propshaft\|rack-test\|terser\|cgi\|net-smtp\|net-imap\|net-pop\|digest\|matrix\|web-console\|error_highlight\|jbuilder\|httpclient\|prism\|useragent\)/ s:^:#:" \
+ -e '/stimulus-rails/,/tailwindcss-rails/ s:^:#:' \
+ -e '/^group :test/,/^end/ s:^:#:' \
+ -e '/^\s*group :\(db\|doc\|rubocop\|job\|cable\|lint\|mdl\|storage\|ujs\|test\|view\) do/,/^\s*end/ s:^:#:' \
+ -e 's/gemspec/gemspec path: "activesupport"/' \
+ -e '5igem "builder"' ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Avoid test that depends on timezone
+ sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
+
+ # Avoid tests that seem to trigger race conditions.
+ rm -f test/evented_file_update_checker_test.rb || die
+
+ # Avoid test that generates filename that is too long
+ sed -i -e '/test_filename_max_size/askip "gentoo"' test/cache/stores/file_store_test.rb || die
+
+ # Avoid tests requiring a live redis running
+ rm -f test/cache/stores/redis_cache_store_test.rb || die
+ sed -i -e '/cache_stores:redis/ s:^:#:' Rakefile || die
+ sed -i -e '/test_redis_cache_store/askip "lacking keywords"' test/cache/cache_store_setting_test.rb || die
+
+ # Avoid test where the result varies with specific ruby releases.
+ rm -f test/core_ext/object/duplicable_test.rb || die
+}