summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 14:55:56 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 15:02:23 +0200
commit8c72f4e6000e12493bdd30f040610fd52cdfb2da (patch)
tree59667812535238002c91d92c113c6b975c1c3e56 /dev-ros/octomap_ros
parentdev-ros/opencv_tests: Remove old (diff)
downloadgentoo-8c72f4e6000e12493bdd30f040610fd52cdfb2da.tar.gz
gentoo-8c72f4e6000e12493bdd30f040610fd52cdfb2da.tar.bz2
gentoo-8c72f4e6000e12493bdd30f040610fd52cdfb2da.zip
dev-ros/octomap_ros: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/octomap_ros')
-rw-r--r--dev-ros/octomap_ros/Manifest1
-rw-r--r--dev-ros/octomap_ros/octomap_ros-0.4.1.ebuild23
-rw-r--r--dev-ros/octomap_ros/octomap_ros-9999.ebuild7
3 files changed, 28 insertions, 3 deletions
diff --git a/dev-ros/octomap_ros/Manifest b/dev-ros/octomap_ros/Manifest
index 00282f524df7..cb26de2dcd6c 100644
--- a/dev-ros/octomap_ros/Manifest
+++ b/dev-ros/octomap_ros/Manifest
@@ -1 +1,2 @@
DIST octomap_ros-0.4.0.tar.gz 5076 BLAKE2B 4c1431d139e7025cae3ac9fa41fa86c71690be58d3177a3a4694f62affc2d61a73eeb456ab78b17c6b63ece8cf9582cff179c4f73ba3520e792a1e819e5ee69b SHA512 41910879d042dcbd969544e89fe40c1da8be75118ef1b813e3cb0319b83529a9c759fe99ed430b275d10d5df987bed7e2b4d7300ed561d159b6007de306bc8ce
+DIST octomap_ros-0.4.1.tar.gz 5879 BLAKE2B a41d8d6688bfc2a182fce6c7b2e032c3cbc7b467c6c8b806adc4e93f371fb49a1aa5d9001b17407d8db33facc3edf868020816a06ff051d5190b9ca5463d6b12 SHA512 692a9f16589b24521440f81f4a55ddaca1778a5bc3c05e30313847300b4012af3a2d2db3786fec7e4a6b7af197c37dc447fded81ab343fcccfa2a4c8810883ab
diff --git a/dev-ros/octomap_ros/octomap_ros-0.4.1.ebuild b/dev-ros/octomap_ros/octomap_ros-0.4.1.ebuild
new file mode 100644
index 000000000000..a45d9828a875
--- /dev/null
+++ b/dev-ros/octomap_ros/octomap_ros-0.4.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/OctoMap/octomap_ros"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Conversion functions between ROS / PCL and OctoMap's native types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf
+ dev-ros/pcl_ros
+ sci-libs/octomap
+"
+DEPEND="${RDEPEND}
+ dev-ros/octomap_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
diff --git a/dev-ros/octomap_ros/octomap_ros-9999.ebuild b/dev-ros/octomap_ros/octomap_ros-9999.ebuild
index b73677241874..a45d9828a875 100644
--- a/dev-ros/octomap_ros/octomap_ros-9999.ebuild
+++ b/dev-ros/octomap_ros/octomap_ros-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/OctoMap/octomap_ros"
KEYWORDS="~amd64 ~arm"
@@ -16,7 +16,8 @@ RDEPEND="
dev-ros/tf
dev-ros/pcl_ros
sci-libs/octomap
+"
+DEPEND="${RDEPEND}
dev-ros/octomap_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
-DEPEND="${RDEPEND}"