summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-10-09 22:23:28 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-10-09 22:27:28 -0400
commit21a434745a59c63d03d39c9b95269b4a21b21854 (patch)
treeb04d4ca7afc20b63913197a59c58609792ac5736 /dev-qt
parentprofiles: Mask reverse dependencies for app-i18n/fcitx:4 (diff)
downloadgentoo-21a434745a59c63d03d39c9b95269b4a21b21854.tar.gz
gentoo-21a434745a59c63d03d39c9b95269b4a21b21854.tar.bz2
gentoo-21a434745a59c63d03d39c9b95269b4a21b21854.zip
dev-qt/qtmultimedia: fix 6.8 build on x86
ebuild's comment is currently incorrect given build system does not pass this, but KDE is planning to upstream it to be passed the same way as PFFFT's so may as well pass it together and leave the comment. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtmultimedia/qtmultimedia-6.8.0.ebuild2
-rw-r--r--dev-qt/qtmultimedia/qtmultimedia-6.8.9999.ebuild2
-rw-r--r--dev-qt/qtmultimedia/qtmultimedia-6.9999.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/dev-qt/qtmultimedia/qtmultimedia-6.8.0.ebuild b/dev-qt/qtmultimedia/qtmultimedia-6.8.0.ebuild
index abc7252aee13..90448d9168fe 100644
--- a/dev-qt/qtmultimedia/qtmultimedia-6.8.0.ebuild
+++ b/dev-qt/qtmultimedia/qtmultimedia-6.8.0.ebuild
@@ -92,7 +92,7 @@ CMAKE_SKIP_TESTS=(
src_configure() {
# normally passed by the build system, but needed for 32-on-64 chroots
- use x86 && append-cppflags -DPFFFT_SIMD_DISABLE
+ use x86 && append-cppflags -DDISABLE_SIMD -DPFFFT_SIMD_DISABLE
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Qml)
diff --git a/dev-qt/qtmultimedia/qtmultimedia-6.8.9999.ebuild b/dev-qt/qtmultimedia/qtmultimedia-6.8.9999.ebuild
index abc7252aee13..90448d9168fe 100644
--- a/dev-qt/qtmultimedia/qtmultimedia-6.8.9999.ebuild
+++ b/dev-qt/qtmultimedia/qtmultimedia-6.8.9999.ebuild
@@ -92,7 +92,7 @@ CMAKE_SKIP_TESTS=(
src_configure() {
# normally passed by the build system, but needed for 32-on-64 chroots
- use x86 && append-cppflags -DPFFFT_SIMD_DISABLE
+ use x86 && append-cppflags -DDISABLE_SIMD -DPFFFT_SIMD_DISABLE
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Qml)
diff --git a/dev-qt/qtmultimedia/qtmultimedia-6.9999.ebuild b/dev-qt/qtmultimedia/qtmultimedia-6.9999.ebuild
index abc7252aee13..90448d9168fe 100644
--- a/dev-qt/qtmultimedia/qtmultimedia-6.9999.ebuild
+++ b/dev-qt/qtmultimedia/qtmultimedia-6.9999.ebuild
@@ -92,7 +92,7 @@ CMAKE_SKIP_TESTS=(
src_configure() {
# normally passed by the build system, but needed for 32-on-64 chroots
- use x86 && append-cppflags -DPFFFT_SIMD_DISABLE
+ use x86 && append-cppflags -DDISABLE_SIMD -DPFFFT_SIMD_DISABLE
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Qml)