summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-30 19:29:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-30 19:29:40 +0200
commitbc1005028c662bc7d0ba1fad03f99d57f97d227b (patch)
tree170a8c2269e559fb5f139cb4529228e6b67c8759 /dev-python
parentdev-python/werkzeug: Remove old (diff)
downloadgentoo-bc1005028c662bc7d0ba1fad03f99d57f97d227b.tar.gz
gentoo-bc1005028c662bc7d0ba1fad03f99d57f97d227b.tar.bz2
gentoo-bc1005028c662bc7d0ba1fad03f99d57f97d227b.zip
dev-python/flask: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/flask/Manifest1
-rw-r--r--dev-python/flask/flask-2.3.2.ebuild59
2 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/flask/Manifest b/dev-python/flask/Manifest
index 03dde47b4e02..b9096bed8fd7 100644
--- a/dev-python/flask/Manifest
+++ b/dev-python/flask/Manifest
@@ -1,3 +1,2 @@
-DIST Flask-2.3.2.tar.gz 686251 BLAKE2B d81553b100e88ab79218422d6d39bb8b186f436c3729985504d1f54536b5e0f783509dcfbf0791890e7c03928131ddd4b8894db51f27e4075c50248ebd7846a2 SHA512 7917c3658a1dec77decad2dbc067a1ae602a66007573f1ff26527c214dede2c455ca5e6490159922fac967ceea99bd880cf929d05e21ed49b08abf501d96e8f8
DIST flask-2.3.3.tar.gz 672756 BLAKE2B 70feb2f1ec8bc4742e8da978b7e1063c5f0bcbfda5321f397cba121283376b5b10a275635eac76383945415dbba3b2c4f917e1495851ee1dfd745db97caddec5 SHA512 801b2521c42de7a4cd16005ea6ea7737aaef6c88edacb38ab03e2d78bb4e080e35e540c23e157e2bcdb43e4818b4b7a856c50c6cf41bb17f0b7b2590c0c6aff2
DIST flask-3.0.0.tar.gz 674171 BLAKE2B 5ae270b429d6ea344828bead0cab855b42f4c28821c843a7754f4741ef0320c190e386a08adb4c6a5018e6a2cc7be588d955ebd4edf31ae59ea9d511c9cd93cb SHA512 dab4f97909619e380e9d8f14cea346dbda8932f3e9d19ee45e3651faf51b94aa5ccaa658116c69abae680f5357235842c63f0c6ff2a191de70cc103f0e7624a4
diff --git a/dev-python/flask/flask-2.3.2.ebuild b/dev-python/flask/flask-2.3.2.ebuild
deleted file mode 100644
index efea6475f841..000000000000
--- a/dev-python/flask/flask-2.3.2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYPI_PN=${PN^}
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
-HOMEPAGE="
- https://palletsprojects.com/p/flask/
- https://github.com/pallets/flask/
- https://pypi.org/project/Flask/
-"
-if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/mitsuhiko/flask.git"
- inherit git-r3
-else
- inherit pypi
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/blinker-1.6.2[${PYTHON_USEDEP}]
- >=dev-python/click-8.1.3[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-2.1.2[${PYTHON_USEDEP}]
- >=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-2.3.3[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/asgiref-3.2[${PYTHON_USEDEP}]
- !!dev-python/shiboken2[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/pallets-sphinx-themes \
- dev-python/sphinx-issues \
- dev-python/sphinx-tabs \
- dev-python/sphinxcontrib-log-cabinet
-distutils_enable_tests pytest
-
-python_test() {
- epytest -p no:httpbin
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- distutils-r1_python_install_all
-}