summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-22 23:24:13 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-23 00:04:18 +0100
commitb0fb9b11197d58fd7a6f26432c94ffbf14b1eea6 (patch)
tree646a14859620b9f51eeb1819883bdea222125df0 /dev-python
parentxfce-base/thunar: Bump to 4.17.7 (diff)
downloadgentoo-b0fb9b11197d58fd7a6f26432c94ffbf14b1eea6.tar.gz
gentoo-b0fb9b11197d58fd7a6f26432c94ffbf14b1eea6.tar.bz2
gentoo-b0fb9b11197d58fd7a6f26432c94ffbf14b1eea6.zip
dev-python/hypothesis: Bump to 6.27.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.27.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 46a4550d4db2..c3dd5541b91b 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-python-6.24.5.tar.gz 9168940 BLAKE2B 719efd5c307708f3fa205e2096e
DIST hypothesis-python-6.24.6.tar.gz 9169209 BLAKE2B 448eedad86d41c766d2bb450f18965592e5f8c53bfc341a081591ae916be00e2a9d5e82633059753e6c47b7905cb09a94e634463cd90bd65c87598f8d92bc58c SHA512 6cd13eb1bf33d5a72debbc262f691949b60ee8bcf6a1c3c263a55b4cc4498c1bd0568088f541ef68152219e9a12d7cfd2a53a3d37a6bba0cec7b2b57b4500e42
DIST hypothesis-python-6.25.0.tar.gz 9170363 BLAKE2B 505aebee64882de9516a653d7906b0d739d2077fd3d2d5bffa2532111d37ca4cdd62ce768dfedf9b9987d1750af7851a015d7feafbed77ab131d15e62f8ec6f1 SHA512 a22ee5632d77dd7c3570b4c5b9faa04c2ee6e7f101d87a3046ee5206b8a444367311573d39c02b12a6ec5b626ab8b89b523bed7e387da59ee3d673601e3f8015
DIST hypothesis-python-6.27.0.tar.gz 9172229 BLAKE2B e5d69923579877a4abaa740663a36510452e10cb782c1c239db03ae22bad9898ba881d808d33ecedaf9319130e619ccadfe87ad9719b1fb05bbcbcd9683d8bba SHA512 54083e0fff2e1af8d3cd91b0e059565091e63058029a501a098228a5b1a411fe652ac542e847c0b03407f9b3f27ca5358b43b15740d6e9e0c882c94ef9e48bad
+DIST hypothesis-python-6.27.1.tar.gz 9173425 BLAKE2B 0fa35a863cbddb9bdd592622247abe7a9bdfc6e4624d1a0913b58a47c29d4c507a1aee8f29f9b6080628894a41140801f567bd5b5f1e83b5505b33089992e10b SHA512 3e2f1d4d268f998ccb6bf3784844d82ff3f276074b13c82fabf87a98441764dcbab576348e77ef4c71cd5f6839f92f978e52571f7e290efc680df984eb2ddebe
diff --git a/dev-python/hypothesis/hypothesis-6.27.1.ebuild b/dev-python/hypothesis/hypothesis-6.27.1.ebuild
new file mode 100644
index 000000000000..119bf66a0917
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.27.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -p no:pytest-describe \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}