summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-20 08:34:14 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-20 08:55:56 +0100
commit3d96a48e8fc6f14998269b8852e25cb4d2597bd3 (patch)
treeba4f673a1fbcb56662b1973a8fddb821b4dcb3e5 /dev-python
parentdev-python/pykka: Remove old (diff)
downloadgentoo-3d96a48e8fc6f14998269b8852e25cb4d2597bd3.tar.gz
gentoo-3d96a48e8fc6f14998269b8852e25cb4d2597bd3.tar.bz2
gentoo-3d96a48e8fc6f14998269b8852e25cb4d2597bd3.zip
dev-python/pykka: Bump to 4.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pykka/Manifest1
-rw-r--r--dev-python/pykka/pykka-4.1.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pykka/Manifest b/dev-python/pykka/Manifest
index 378d5f35fc56..07968cabfdc6 100644
--- a/dev-python/pykka/Manifest
+++ b/dev-python/pykka/Manifest
@@ -1 +1,2 @@
DIST pykka-4.1.0.gh.tar.gz 48569 BLAKE2B 7b97988d543cb6205c698cb91d292aae8312b5e0ccffc8113af0201a97abf01d67e15b2440c2d2473f7005a3e5cb475fa55d333f332f44e0995a4a0e07c9cf95 SHA512 ffb83329f3fc7dc9caa0d63e17138186286975259573540842eb8840e383cabc1959827659de22360fd6542332865f38fb23f75c89a16e224360ef4dbc33ecc4
+DIST pykka-4.1.1.gh.tar.gz 48728 BLAKE2B 4c3f0bf5454c6af04a91ebecc562e34dad257f61cca1aa20e11deea6fb524d0fa1bb86d4dd0829fe8392f57c6fd6c49b1b50abb74f08b77bccf4219d91abb5f7 SHA512 99f8738dbd0a4172e9c8a2cdbfe36335e349f8b0e421ab53ad2869e4250e6c03e69b89eea30e05c015a0203e0e6191b421f23061aa3aab869bb4383cc6ed0d49
diff --git a/dev-python/pykka/pykka-4.1.1.ebuild b/dev-python/pykka/pykka-4.1.1.ebuild
new file mode 100644
index 000000000000..74fa9c7b7177
--- /dev/null
+++ b/dev-python/pykka/pykka-4.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python implementation of the actor model"
+HOMEPAGE="
+ https://pykka.org/en/latest/
+ https://github.com/jodal/pykka/
+ https://pypi.org/project/pykka/
+"
+SRC_URI="
+ https://github.com/jodal/pykka/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ >=dev-python/pydantic-2.9[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest