summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-30 17:33:11 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-30 18:01:23 +0200
commit0e3555c60e10dc55e7a2b7b8a5a348b3d1088518 (patch)
tree210a4c123dd2908cbb3ce914d11e849bf7c5e91c /dev-python
parentRename dev-python/{stack-data → stack-data} (diff)
downloadgentoo-0e3555c60e10dc55e7a2b7b8a5a348b3d1088518.tar.gz
gentoo-0e3555c60e10dc55e7a2b7b8a5a348b3d1088518.tar.bz2
gentoo-0e3555c60e10dc55e7a2b7b8a5a348b3d1088518.zip
dev-python/stack-data: Bump to 0.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/stack-data/Manifest1
-rw-r--r--dev-python/stack-data/stack-data-0.6.3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/stack-data/Manifest b/dev-python/stack-data/Manifest
index 49fbecb4576b..2ebcdccea8df 100644
--- a/dev-python/stack-data/Manifest
+++ b/dev-python/stack-data/Manifest
@@ -1 +1,2 @@
DIST stack_data-0.6.2.tar.gz 44146 BLAKE2B 1344b48a597af3df3a00036412c513faa97824f183a4337566a1a8efafcb6ec6597cf5fad3c6d532e8df2173900bdf87d0071efc66a801bd93743a92619fb5dd SHA512 cdc623f8efc2fc4a968fd537c2147f4de90c0878554b3d3d741cf916ae549da8756d6ac943dbdee94721cc6a0c433d04d73e30bccee2b4ec1f5027efc3c9b90d
+DIST stack_data-0.6.3.tar.gz 44707 BLAKE2B d50e8c8e925cd9a4a19f883422aa487543836b36e20861f9bdf41551484ba02f7bdfb729f8bc051b3a97e76b4df7e7833b53bd3c47daf85dc2aa4e8d5d1c11b1 SHA512 629c112c09a1f69566160039c4d5fd49e59bdc206ad76799c67418e08b93a0990dd802078b646da175ab719b448394b723aab37479be14d09c0fb1c72cdbd0b8
diff --git a/dev-python/stack-data/stack-data-0.6.3.ebuild b/dev-python/stack-data/stack-data-0.6.3.ebuild
new file mode 100644
index 000000000000..cfcde8aab223
--- /dev/null
+++ b/dev-python/stack-data/stack-data-0.6.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Extract data from Python tracebacks for informative displays"
+HOMEPAGE="
+ https://github.com/alexmojaki/stack_data/
+ https://pypi.org/project/stack-data/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/asttokens-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/executing-1.2.0[${PYTHON_USEDEP}]
+ dev-python/pure_eval[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/typeguard[${PYTHON_USEDEP}]
+ dev-python/littleutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Cython looks for the module in the wrong directory, for some reason
+ tests/test_formatter.py::test_example
+)