summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-30 10:31:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-30 10:31:22 +0200
commit06f1764e3d548a6cba44e65bfab4228ca2c57228 (patch)
tree38fa9d9a61bc4b91adf92cbbfc0efb29d064682f /dev-python
parentdev-python/aesara: Stabilize 2.9.2 ALLARCHES, #914963 (diff)
downloadgentoo-06f1764e3d548a6cba44e65bfab4228ca2c57228.tar.gz
gentoo-06f1764e3d548a6cba44e65bfab4228ca2c57228.tar.bz2
gentoo-06f1764e3d548a6cba44e65bfab4228ca2c57228.zip
dev-python/aesara: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aesara/Manifest1
-rw-r--r--dev-python/aesara/aesara-2.9.1.ebuild105
2 files changed, 0 insertions, 106 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
index 4d967877b2a9..14978b32a779 100644
--- a/dev-python/aesara/Manifest
+++ b/dev-python/aesara/Manifest
@@ -1,2 +1 @@
-DIST aesara-2.9.1.tar.gz 4423120 BLAKE2B 7a9b789cf455a85baa48be20112e42a5449c955a57327125356968cbc8a9657d083a7aaa47048d322be05a822250f6c5cb50ff838b957595814d19499166e555 SHA512 17aa8f901a3194f82e4e47c78f23c91bb07ccfed7664e807537cd9db8d92f892357b1a7219b58881c16308b13689d088eaadcf113e17389e3f1297fc1d5e9381
DIST aesara-2.9.2.tar.gz 4424417 BLAKE2B d5e40ecdba51d32ee160efe287d11ee96cf00fbea2882a5bfbba08099edf12e449f56eb3af636cb50b675d6aacc4270ee57c30d3c6848abd9a925285a91df7ae SHA512 91cf78fe4ee107895f91365adce6b4446c0a6908e36ebba407a9ad896af9dd38d035c0cd08515ca7789a052ad1c1f34930b46e8196768ebbcf27e8f37c1053a3
diff --git a/dev-python/aesara/aesara-2.9.1.ebuild b/dev-python/aesara/aesara-2.9.1.ebuild
deleted file mode 100644
index 04cfcd712e77..000000000000
--- a/dev-python/aesara/aesara-2.9.1.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 multiprocessing optfeature pypi
-
-DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
-HOMEPAGE="
- https://github.com/aesara-devs/aesara/
- https://pypi.org/project/aesara/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-RDEPEND="
- dev-python/cons[${PYTHON_USEDEP}]
- dev-python/etuples[${PYTHON_USEDEP}]
- dev-python/logical-unification[${PYTHON_USEDEP}]
- dev-python/minikanren[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- <dev-python/numpy-1.25[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/aesara-2.6.5-compiledir-tid.patch
- "${FILESDIR}"/aesara-2.8.10-fix-tuple.patch
-)
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # do not claim "bin" package (sic!)
- rm bin/__init__.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # speed tests are unreliable
- tests/scan/test_basic.py::test_speed
- tests/scan/test_basic.py::test_speed_rnn
- tests/scan/test_basic.py::test_speed_batchrnn
- tests/link/test_vm.py::test_speed
- tests/link/test_vm.py::test_speed_lazy
- tests/tensor/test_gc.py::test_merge_opt_runtime
-
- # rounding problem?
- # https://github.com/aesara-devs/aesara/issues/477
- tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
- tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
-
- # Deprecation warning causes unexpected additional output
- tests/tensor/test_basic.py::TestLongTensor::test_fit_int64
-
- # dunno
- tests/tensor/test_elemwise.py::TestDimShuffle::test_memory_leak
- tests/tensor/signal/test_pool.py::TestDownsampleFactorMax::test_DownsampleFactorMaxGradGrad_grad
-
- # TODO
- tests/link/c/test_op.py::test_ExternalCOp_c_code_cache_version
- tests/sparse/sandbox/test_sp.py::TestSP::test_multilayer_conv
- tests/sparse/sandbox/test_sp.py::TestSP::test_maxpool
-
- # TODO: Package pytest-benchmark
- tests/scan/test_basic.py::TestExamples::test_reordering
- tests/scan/test_basic.py::TestExamples::test_scan_as_tensor_on_gradients
- tests/scan/test_basic.py::TestExamples::test_multiple_outs_taps
- tests/scan/test_rewriting.py::TestPushOutAddScan::test_pregreedy_optimizer
- tests/scan/test_rewriting.py::TestSaveMem::test_savemem_opt
- tests/scan/test_basic.py::test_cython_performance
- )
- local EPYTEST_IGNORE=(
- # we do not package jax or numba
- tests/link/jax
- tests/link/numba
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x AESARA_FLAGS="cxx=${CXX}"
- AESARA_FLAGS+=",config.gcc__cxxflags=\"${CXXFLAGS}\""
- AESARA_FLAGS+=',compiledir_format="compiledir_%(thread_id)s"'
-
- epytest -p xdist.plugin -n "$(makeopts_jobs)" --dist=worksteal
- # clean up the compiledir, as it can grow pretty large
- rm -r "${HOME}"/.aesara || die
-}
-
-pkg_postinst() {
- optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit
- optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
-}