summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-05 15:35:00 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-05 15:35:00 +0200
commitcc8acc557ff0bf5c0080932b2d878cfffe86f7c3 (patch)
treebc6e9422ac7bb52fbeb60911d85c39d9cb8d9ef5 /dev-python/zope-hookable
parentdev-python/rpds-py: Bump to 0.10.4 (diff)
downloadgentoo-cc8acc557ff0bf5c0080932b2d878cfffe86f7c3.tar.gz
gentoo-cc8acc557ff0bf5c0080932b2d878cfffe86f7c3.tar.bz2
gentoo-cc8acc557ff0bf5c0080932b2d878cfffe86f7c3.zip
dev-python/zope-hookable: Bump to 6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zope-hookable')
-rw-r--r--dev-python/zope-hookable/Manifest1
-rw-r--r--dev-python/zope-hookable/zope-hookable-6.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/zope-hookable/Manifest b/dev-python/zope-hookable/Manifest
index ea9bf6f8fcd1..4d1b959c0698 100644
--- a/dev-python/zope-hookable/Manifest
+++ b/dev-python/zope-hookable/Manifest
@@ -1 +1,2 @@
DIST zope.hookable-5.4.tar.gz 25390 BLAKE2B 6421e21d03cc4f7ab55c327b2b07d26e8873567d8730382bdc51cff8131e452c72b8a8accbda5698b7b63006c923823f1689800d7145601dab0af66def42c705 SHA512 aaa1c15927b19c6785de31171d7856b3e60755965538f923b26bba7048e6816749587b55a4dbbe555822021fc77d8ffd2705c4bbcf79016f4bbdc5c75c8ffdad
+DIST zope.hookable-6.0.tar.gz 24013 BLAKE2B 808005d0993e22967bc7a73a7b8a26f2263dfc9f3f33d840495a233ea8686a5e700ee46cf0dad8e37aeebb0383ec51b15a4f98323daf4d6bb606fc1ab149f39e SHA512 33d1200a24fc664ed9c7942f71b003704fda21ac42f5acc24611838aa4e8096a27a5da01956ec824105d454a0580480ce8a262c8f5c4f24782ab11416d9fdafd
diff --git a/dev-python/zope-hookable/zope-hookable-6.0.ebuild b/dev-python/zope-hookable/zope-hookable-6.0.ebuild
new file mode 100644
index 000000000000..2301c89ed21a
--- /dev/null
+++ b/dev-python/zope-hookable/zope-hookable-6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Efficient creation of 'hookable' objects"
+HOMEPAGE="
+ https://pypi.org/project/zope.hookable/
+ https://github.com/zopefoundation/zope.hookable/
+"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ eunittest -s "${BUILD_DIR}/install$(python_get_sitedir)/zope/hookable/tests"
+}