summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-29 05:49:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-29 06:21:13 +0200
commit7096a263cde88ffbd6adb4b56affea715bab6597 (patch)
treecda36bc6ce9757480570040af0c63f3ff956ec9c /dev-python/uv
parentapp-admin/awscli: Bump to 1.34.8 (diff)
downloadgentoo-7096a263cde88ffbd6adb4b56affea715bab6597.tar.gz
gentoo-7096a263cde88ffbd6adb4b56affea715bab6597.tar.bz2
gentoo-7096a263cde88ffbd6adb4b56affea715bab6597.zip
dev-python/uv: Bump to 0.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uv')
-rw-r--r--dev-python/uv/Manifest1
-rw-r--r--dev-python/uv/uv-0.4.0.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/dev-python/uv/Manifest b/dev-python/uv/Manifest
index d71ccc06ec0f..d8550d10dc97 100644
--- a/dev-python/uv/Manifest
+++ b/dev-python/uv/Manifest
@@ -8,3 +8,4 @@ DIST uv-0.3.4-crates.tar.xz 48658524 BLAKE2B 51a3a4883f8c435355ebb6da3da5bdc8d2d
DIST uv-0.3.4.gh.tar.gz 2458698 BLAKE2B 89db8580a2b3e04546a82bdeb916660cd25344ce604f4201f71bad047ec2e8af651a81d8793207e43755f06e9d69c2fa3afe7386113c0fd79e683964f4a8dd56 SHA512 a99e6963f0ccd6becfdd6802b6195d5ebf5e2563d3fbad3d09ca5302d1d3fcf4fcdf9d2c5837023fef09ea89f5cf736ac61005d4c0e6f824d5a0c64160183686
DIST uv-0.3.5-crates.tar.xz 48793516 BLAKE2B 49ada395e1834a3c5ec7835a2a23cea885ec111250e4fccc8d78558b561938e12cdb1de643a1b84383a5aa1abfca916d1f4d06fe2dbe69ef47092ddbed06a367 SHA512 d3d2d5a33c91f4dd6397d60d4877d8501136e74291bd214d5b54593f4b9aa246015c58caab5de4e6b5b7040c9d6bd41478a800bb92957df8f12da81d5b843030
DIST uv-0.3.5.gh.tar.gz 2471050 BLAKE2B 5c089260e5091042c88307fa71f24e773eea80e959c27273781e13f50ef1e08e17220586f6661703ec9e9b58200eb974b311501f3f32fd7862a4a0b185d03bbc SHA512 0d7842aad0f0da030b1d336f962eb1252247bb62e24c2a0ba97fb2f13cfc9f48ba0a1aac42770be93fda8e5e08a59462a242c8ea95a9c97dc56959492cf5c6db
+DIST uv-0.4.0.gh.tar.gz 2486795 BLAKE2B 9eac98c81e4f9c7631c3ee49ab9edfb3a9191417abfbf4ae79f6c6ed9172eef28669b49f1bc41aa1cc1bad403e55002a9ef269a5f76540395c7eb90b97ff3ac1 SHA512 e138bead288743923a695ffae0ca1eae88e94cc39c209be7a263bf1da644702922f32becfc33954f9a354b69307bce4ca545684a0757499ac5c93d121405c68c
diff --git a/dev-python/uv/uv-0.4.0.ebuild b/dev-python/uv/uv-0.4.0.ebuild
new file mode 100644
index 000000000000..72bc0ed13457
--- /dev/null
+++ b/dev-python/uv/uv-0.4.0.ebuild
@@ -0,0 +1,113 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+"
+
+declare -A GIT_CRATES=(
+ [async_zip]='https://github.com/charliermarsh/rs-async-zip;011b24604fa7bc223daaad7712c0694bac8f0a87;rs-async-zip-%commit%'
+ [pubgrub]='https://github.com/astral-sh/pubgrub;388685a8711092971930986644cfed152d1a1f6c;pubgrub-%commit%'
+ [reqwest-middleware]='https://github.com/astral-sh/reqwest-middleware;5e3eaf254b5bd481c75d2710eed055f95b756913;reqwest-middleware-%commit%/reqwest-middleware'
+ [reqwest-retry]='https://github.com/astral-sh/reqwest-middleware;5e3eaf254b5bd481c75d2710eed055f95b756913;reqwest-middleware-%commit%/reqwest-retry'
+ [tl]='https://github.com/charliermarsh/tl;6e25b2ee2513d75385101a8ff9f591ef51f314ec;tl-%commit%'
+)
+
+inherit cargo check-reqs
+
+CRATE_PV=0.3.5
+DESCRIPTION="A Python package installer and resolver, written in Rust"
+HOMEPAGE="
+ https://github.com/astral-sh/uv/
+ https://pypi.org/project/uv/
+"
+# pypi sdist misses scripts/, needed for tests
+SRC_URI="
+ https://github.com/astral-sh/uv/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/uv-${CRATE_PV}-crates.tar.xz
+ "
+fi
+
+# most of the code
+LICENSE="|| ( Apache-2.0 MIT )"
+# crates/pep508-rs is || ( Apache-2.0 BSD-2 ) which is covered below
+# Dependent crate licenses
+LICENSE+="
+ 0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD ISC MIT
+ MPL-2.0 Unicode-DFS-2016
+"
+# ring crate
+LICENSE+=" openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+BDEPEND="
+ >=virtual/rust-1.80
+ test? (
+ dev-lang/python:3.8
+ dev-lang/python:3.9
+ dev-lang/python:3.10
+ dev-lang/python:3.11
+ dev-lang/python:3.12
+ )
+"
+
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+check_space() {
+ local CHECKREQS_DISK_BUILD=3G
+ use debug && CHECKREQS_DISK_BUILD=9G
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ check_space
+}
+
+pkg_setup() {
+ check_space
+}
+
+src_prepare() {
+ default
+
+ # remove patch.* that breaks GIT_CRATES
+ local reqmw=${GIT_CRATES[reqwest-middleware]}
+ reqmw=${reqmw#*;}
+ reqmw=${reqmw%;*}
+ sed -i -e "/^\[patch/,\$s@^\(reqwest-middleware = \).*@\1 { path = \"${WORKDIR}/reqwest-middleware-${reqmw}/reqwest-middleware\" }@" Cargo.toml || die
+
+ # https://github.com/vorot93/tokio-tar/pull/23
+ # (fortunately uv already depends on portable-atomic, so we don't
+ # have to fight Cargo.lock)
+ cd "${ECARGO_VENDOR}/tokio-tar-0.3.1" || die
+ eapply "${FILESDIR}/tokio-tar-0.3.1-ppc.patch"
+}
+
+src_compile() {
+ cd crates/uv || die
+ cargo_src_compile
+}
+
+src_test() {
+ # work around https://github.com/astral-sh/uv/issues/4376
+ local -x PATH=${BROOT}/usr/lib/python-exec/python3.12:${PATH}
+ local -x COLUMNS=100
+
+ cd crates/uv || die
+ cargo_src_test --no-fail-fast
+}
+
+src_install() {
+ cd crates/uv || die
+ cargo_src_install
+}