summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-30 22:39:45 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-30 22:39:45 +0100
commit31417f07a98effb61b2dc51f9ce9da0b0d3360b5 (patch)
tree5e61133e8429dfb4df59084fe7d12fd9c91ce5f8 /dev-python/thunarx-python
parentacct-user/dbmail: Add new user for net-mail/dbmail (diff)
downloadgentoo-31417f07a98effb61b2dc51f9ce9da0b0d3360b5.tar.gz
gentoo-31417f07a98effb61b2dc51f9ce9da0b0d3360b5.tar.bz2
gentoo-31417f07a98effb61b2dc51f9ce9da0b0d3360b5.zip
dev-python/thunarx-python: port to EAPI 7
* Fix build with gcc-10. Thanks to Sam James for providing the patch link Closes: https://bugs.gentoo.org/710948 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/thunarx-python')
-rw-r--r--dev-python/thunarx-python/files/thunarx-python-0.5.1-fno-common.patch85
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild15
2 files changed, 93 insertions, 7 deletions
diff --git a/dev-python/thunarx-python/files/thunarx-python-0.5.1-fno-common.patch b/dev-python/thunarx-python/files/thunarx-python-0.5.1-fno-common.patch
new file mode 100644
index 000000000000..21f55c0e6f8e
--- /dev/null
+++ b/dev-python/thunarx-python/files/thunarx-python-0.5.1-fno-common.patch
@@ -0,0 +1,85 @@
+Taken from: https://git.xfce.org/bindings/thunarx-python/commit/?id=3037ebe25d5c6ed58699e56b61f657cea3e5a5a6
+Author: Mukundan Ragavan <nonamedotc@gmail.com>
+
+--- a/src/thunarx-python-object.c
++++ b/src/thunarx-python-object.c
+@@ -24,6 +24,7 @@
+
+ #include <thunarx/thunarx.h>
+
++#define NO_IMPORT_PYGOBJECT
+ #include <pygobject.h>
+
+ #include <string.h>
+--- a/src/thunarx-python.c
++++ b/src/thunarx-python.c
+@@ -30,6 +30,18 @@
+ #include "thunarx-python.h"
+ #include "thunarx-python-object.h"
+
++PyTypeObject *_PyGtkWidget_Type;
++PyTypeObject *_PyThunarxFileInfo_Type;
++PyTypeObject *_PyThunarxMenuItem_Type;
++PyTypeObject *_PyThunarxMenu_Type;
++PyTypeObject *_PyThunarxMenuProvider_Type;
++PyTypeObject *_PyThunarxPreferencesProvider_Type;
++PyTypeObject *_PyThunarxPropertyPage_Type;
++PyTypeObject *_PyThunarxPropertyPageProvider_Type;
++PyTypeObject *_PyThunarxProviderPlugin_Type;
++PyTypeObject *_PyThunarxRenamer_Type;
++PyTypeObject *_PyThunarxRenamerProvider_Type;
++
+ static const GDebugKey thunarx_python_debug_keys[] = {
+ {"all", THUNARX_PYTHON_DEBUG_ALL},
+ };
+--- a/src/thunarx-python.h
++++ b/src/thunarx-python.h
+@@ -43,37 +43,37 @@ extern ThunarxPythonDebug thunarx_python_debug;
+ #define debug_enter_args(x, y) { if (thunarx_python_debug & THUNARX_PYTHON_DEBUG_ALL) \
+ g_printf("%s: entered " x "\n", __FUNCTION__, y); }
+
+-PyTypeObject *_PyGtkWidget_Type;
++extern PyTypeObject *_PyGtkWidget_Type;
+ #define PyGtkWidget_Type (*_PyGtkWidget_Type)
+
+-PyTypeObject *_PyThunarxFileInfo_Type;
++extern PyTypeObject *_PyThunarxFileInfo_Type;
+ #define PyThunarxFileInfo_Type (*_PyThunarxFileInfo_Type)
+
+-PyTypeObject *_PyThunarxMenuItem_Type;
++extern PyTypeObject *_PyThunarxMenuItem_Type;
+ #define PyThunarxMenuItem_Type (*_PyThunarxMenuItem_Type)
+
+-PyTypeObject *_PyThunarxMenu_Type;
++extern PyTypeObject *_PyThunarxMenu_Type;
+ #define PyThunarxMenu_Type (*_PyThunarxMenu_Type)
+
+-PyTypeObject *_PyThunarxMenuProvider_Type;
++extern PyTypeObject *_PyThunarxMenuProvider_Type;
+ #define PyThunarxMenuProvider_Type (*_PyThunarxMenuProvider_Type)
+
+-PyTypeObject *_PyThunarxPreferencesProvider_Type;
++extern PyTypeObject *_PyThunarxPreferencesProvider_Type;
+ #define PyThunarxPreferencesProvider_Type (*_PyThunarxPreferencesProvider_Type)
+
+-PyTypeObject *_PyThunarxPropertyPage_Type;
++extern PyTypeObject *_PyThunarxPropertyPage_Type;
+ #define PyThunarxPropertyPage_Type (*_PyThunarxPropertyPage_Type)
+
+-PyTypeObject *_PyThunarxPropertyPageProvider_Type;
++extern PyTypeObject *_PyThunarxPropertyPageProvider_Type;
+ #define PyThunarxPropertyPageProvider_Type (*_PyThunarxPropertyPageProvider_Type)
+
+-PyTypeObject *_PyThunarxProviderPlugin_Type;
++extern PyTypeObject *_PyThunarxProviderPlugin_Type;
+ #define PyThunarxProviderPlugin_Type (*_PyThunarxProviderPlugin_Type)
+
+-PyTypeObject *_PyThunarxRenamer_Type;
++extern PyTypeObject *_PyThunarxRenamer_Type;
+ #define PyThunarxRenamer_Type (*_PyThunarxRenamer_Type)
+
+-PyTypeObject *_PyThunarxRenamerProvider_Type;
++extern PyTypeObject *_PyThunarxRenamerProvider_Type;
+ #define PyThunarxRenamerProvider_Type (*_PyThunarxRenamerProvider_Type)
+
+ #endif /* THUNARX_PYTHON_H */
diff --git a/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild b/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
index d2bb115a4a8c..08d8b303c2db 100644
--- a/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
+++ b/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
inherit python-single-r1
@@ -13,21 +13,22 @@ SRC_URI="https://archive.xfce.org/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
RDEPEND="${PYTHON_DEPS}
- >=x11-libs/gtk+-3.20:3
>=dev-libs/glib-2.30:2
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/thunar-1.7.0
$(python_gen_cond_dep '
>=dev-python/pygobject-3.20:3[${PYTHON_MULTI_USEDEP}]
- ')
- >=xfce-base/thunar-1.7.0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ ')"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
REQUIRED_USE=${PYTHON_REQUIRED_USE}
PATCHES=(
"${FILESDIR}"/${P}-py38.patch
+ "${FILESDIR}"/${P}-fno-common.patch
)
src_install() {