summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-31 23:35:32 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-01 00:46:53 +0100
commit78a00aa42924776e8006ff860502a6d8c9f1f7c7 (patch)
treea13d4f15d224e8eae69db8c7f7960a1dcfc3350e /dev-python/threadpoolctl
parentdev-python/ansi: Bump to 0.3.5 (diff)
downloadgentoo-78a00aa42924776e8006ff860502a6d8c9f1f7c7.tar.gz
gentoo-78a00aa42924776e8006ff860502a6d8c9f1f7c7.tar.bz2
gentoo-78a00aa42924776e8006ff860502a6d8c9f1f7c7.zip
dev-python/threadpoolctl: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/threadpoolctl')
-rw-r--r--dev-python/threadpoolctl/Manifest1
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-3.1.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/threadpoolctl/Manifest b/dev-python/threadpoolctl/Manifest
index a8c27843f8f0..e7396707fda4 100644
--- a/dev-python/threadpoolctl/Manifest
+++ b/dev-python/threadpoolctl/Manifest
@@ -1 +1,2 @@
DIST threadpoolctl-3.0.0.tar.gz 28486 BLAKE2B e49bf43ea272e353e1a5f864cd7f38978793489b2dba60a1c075a61f6dbfe0a75a456e1143c0f33d3222ff2e27c1ce6025579b00e3feb2d789c7be068f6e07ad SHA512 df0829d5bed15d5cbcd502810aff91c9dd0d4dafc11173aa762426e96a7ed5acb0fd3132161e5b2d234136156f2a599c3592fc0a8e20828db83882b840a939cc
+DIST threadpoolctl-3.1.0.tar.gz 29899 BLAKE2B 41bddace1231107a108fd57e281541a4e9f04c9bee957d16cfbff49361f9dcb0b879bf376617480b1ca2929c09d07fd1f8f704afa4ad85e34e38c4a82fb48a3c SHA512 551dad4c93a62382583a96187f795aaeb6954700647c984ad618d3d1bede50d6859e75f676c557fa875db37c798c0347131f6b136148f71b8208783c7f8f717e
diff --git a/dev-python/threadpoolctl/threadpoolctl-3.1.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-3.1.0.ebuild
new file mode 100644
index 000000000000..8665d7222a6d
--- /dev/null
+++ b/dev-python/threadpoolctl/threadpoolctl-3.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Limit the number of threads used in native libs that have their own threadpool"
+HOMEPAGE="https://github.com/joblib/threadpoolctl"
+SRC_URI="https://github.com/joblib/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest