summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-10 09:07:48 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-10 09:34:13 +0200
commit5982cb758c74f76602cf0d4f2df0a50958e9d10f (patch)
tree8230207c7a3e49989fa2217f226abf0d7638cf59 /dev-python/threadpoolctl
parentdev-python/google-api-core: Bump to 1.31.0 (diff)
downloadgentoo-5982cb758c74f76602cf0d4f2df0a50958e9d10f.tar.gz
gentoo-5982cb758c74f76602cf0d4f2df0a50958e9d10f.tar.bz2
gentoo-5982cb758c74f76602cf0d4f2df0a50958e9d10f.zip
dev-python/threadpoolctl: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/threadpoolctl')
-rw-r--r--dev-python/threadpoolctl/Manifest1
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-2.2.0.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/threadpoolctl/Manifest b/dev-python/threadpoolctl/Manifest
index 4c8c9ea54fc7..f8db3eb3ef6c 100644
--- a/dev-python/threadpoolctl/Manifest
+++ b/dev-python/threadpoolctl/Manifest
@@ -1 +1,2 @@
DIST threadpoolctl-2.1.0.tar.gz 25255 BLAKE2B 3afa8e8c44567d3833dee89e761b2f384129c386c5c5b9d8084c1b301f007be7f461f1ef99738e06551f793feefa5c312dce1d608e7012215fd759866a52e2d4 SHA512 09b745b0d164bf3fc4f293bd92f1fd2e02180ec538bf3da1cdb986e31d9336ba3e1301aede72f53700d00298bae7b91b4ec8fa3212accb4cde6c3f5f88ff5c62
+DIST threadpoolctl-2.2.0.tar.gz 25875 BLAKE2B 4fc77efb181a91888d2d47cf1f9fa67157366e3ce33a958244b606019389624e83b1903581bfe88f8b4c798b4a8f07d0a50269282efaa323d3cae9f3d5ea8258 SHA512 edc310a9447b1782cedc98aadd065ce9291eca04518f6223090c1dd57f714b85f32293f16cfc1d95639130db47aa04806cac77a42922471e07582293416450fc
diff --git a/dev-python/threadpoolctl/threadpoolctl-2.2.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-2.2.0.ebuild
new file mode 100644
index 000000000000..73d734dc2381
--- /dev/null
+++ b/dev-python/threadpoolctl/threadpoolctl-2.2.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Limit the number of threads used in native libs that have their own threadpool"
+HOMEPAGE="https://github.com/joblib/threadpoolctl"
+SRC_URI="https://github.com/joblib/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest