summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-09 19:33:49 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-09 20:28:55 +0300
commit3cc896162cb87b97a9e046fd8d6b56c0ac10b308 (patch)
tree3e081b0a3d1c81e4694cdbb4b4443c8732e75df4 /dev-python/stapler
parentdev-python/PyUtilib: mark ALLARCHES (diff)
downloadgentoo-3cc896162cb87b97a9e046fd8d6b56c0ac10b308.tar.gz
gentoo-3cc896162cb87b97a9e046fd8d6b56c0ac10b308.tar.bz2
gentoo-3cc896162cb87b97a9e046fd8d6b56c0ac10b308.zip
dev-python/stapler: enable py3.10, EAPI=8, enable tests
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/stapler')
-rw-r--r--dev-python/stapler/stapler-1.0.0_p20200531-r2.ebuild (renamed from dev-python/stapler/stapler-1.0.0_p20200531-r1.ebuild)11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-python/stapler/stapler-1.0.0_p20200531-r1.ebuild b/dev-python/stapler/stapler-1.0.0_p20200531-r2.ebuild
index d71209069acb..2ded93bb400a 100644
--- a/dev-python/stapler/stapler-1.0.0_p20200531-r1.ebuild
+++ b/dev-python/stapler/stapler-1.0.0_p20200531-r2.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=pyproject.toml
-inherit distutils-r1 vcs-snapshot
+inherit distutils-r1
COMMIT="1cabc85521e2badfc1e0d690086e286e701c2d9e"
DESCRIPTION="Suite of tools for PDF files manipulation written in Python"
HOMEPAGE="https://github.com/hellerbarde/stapler"
SRC_URI="https://github.com/hellerbarde/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
LICENSE="BSD"
SLOT="0"
@@ -22,6 +23,4 @@ RDEPEND="
dev-python/PyPDF2[${PYTHON_USEDEP}]
"
-DEPEND="
- ${RDEPEND}
-"
+distutils_enable_tests unittest