summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-10 04:58:31 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-10 04:58:31 +0100
commitdd1ba8ad190f7176aa6840325cbde63535383987 (patch)
tree06577899166689664b37f236a8e1719216477447 /dev-python/sqlglot
parentprofiles/base: Stable-mask postgres16 target (diff)
downloadgentoo-dd1ba8ad190f7176aa6840325cbde63535383987.tar.gz
gentoo-dd1ba8ad190f7176aa6840325cbde63535383987.tar.bz2
gentoo-dd1ba8ad190f7176aa6840325cbde63535383987.zip
dev-python/sqlglot: Bump to 19.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sqlglot')
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-19.2.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index 6562c20e5390..0b8bdb4a9585 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -3,3 +3,4 @@ DIST sqlglot-19.0.2.tar.gz 8980868 BLAKE2B 07e6d0af365a45cdac27e7b976979bbd26b36
DIST sqlglot-19.0.3.tar.gz 8998735 BLAKE2B ca9b3470f0a3a6c2997c1533b61cdb4ad96895e92fdf3ce924d3cd20af1dc3689ae08897fa3a340051742dff056fc927fa4d5037d23a681b87feb923d2a3731a SHA512 183a90c45a495a204cf00363a50a8fb39d9f37cf05f6b310611cbd5e85f47913d70c3476c6091e1e4b88d23aa1f3196b81bd45e29ad0e5a9ad4ad98b8dbd9fd8
DIST sqlglot-19.1.1.tar.gz 9031814 BLAKE2B 75430d912007d6edf3f045a21f68f35a3dd029d57d43c76fbdb7b10cd4e5e27778a7e86ca2100e8dfee63908ed78943180b45cea919b1f1b0d7d59a491ccbd21 SHA512 d2652f21e77eb31651f7cfddf2f3b0b1db18174e0409cc7bc7b4cae7c18c8bdc89a007b5a122de35573096b28580a2a47401e4dcf2bbf1b92b10f4d09f424f2b
DIST sqlglot-19.1.2.tar.gz 9032813 BLAKE2B 5ed47175decfcdcdf116a5c8676a25f2682ea084d8ddab4c8c147939c159c8c9a2392ebf6466ee32609bb76b86ffe15cd2e7191948067d9ee11e3cdf135331a0 SHA512 e790aedc4c8e5907588e414334121eacfb57f317f06c6c61309a3d932bbb5a1696e2582c5c1cbe5f61a1a85087255dbbb1616dc2f8b19888f80055afc517731c
+DIST sqlglot-19.2.0.tar.gz 9042951 BLAKE2B fd9b70c76f7bcc1ba57bb935d5896de794a981214c23af48b20948d04b7110841ab5fb931aa541101635d723bdb6c395d983a856d598118586d1bc582e341be8 SHA512 4c50f8e7faac643f95c9f9fec6a9ecf797d5f1fa8d8dea10496a320a2a78ab1ba6a3349a47ab1bfca8adc3cb2ad795e56a27d6de7b77256dae65d8ce1a3a9c56
diff --git a/dev-python/sqlglot/sqlglot-19.2.0.ebuild b/dev-python/sqlglot/sqlglot-19.2.0.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-19.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}