summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-28 06:27:30 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-28 06:43:50 +0200
commite354f921b1b7925c315a32c0a5232a7f4de297b5 (patch)
tree665df1d9ac9e6b9812ad63371788921843781fe1 /dev-python/rope
parentdev-python/gsd: Bump to 3.2.0 (diff)
downloadgentoo-e354f921b1b7925c315a32c0a5232a7f4de297b5.tar.gz
gentoo-e354f921b1b7925c315a32c0a5232a7f4de297b5.tar.bz2
gentoo-e354f921b1b7925c315a32c0a5232a7f4de297b5.zip
dev-python/rope: Bump to 1.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/rope-1.10.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index 58b60c627ae2..b91a9dbfb0e7 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1 +1,2 @@
+DIST rope-1.10.0.tar.gz 299732 BLAKE2B bc8b276eb1e69730536d947ffb167bef3dd2dfa453c1834349e78ceb1dda56aa51cff556687bbebaca4e0cad1055da0db5294e029be59d525bc170564bfe3870 SHA512 3a8c31a89f14a78f9a0931e87e21b0a617891382e879b50a6fa846ad576ad6bf62f81ccd8c00bd237b77807832a760120256655ac4d6a73626c0b0f1b5c61100
DIST rope-1.9.0.tar.gz 298227 BLAKE2B c136678bdd9d580d0f0ada93e5c61b963bfe5b9867b39f8c9ba35578f4c8b2ebca1031d00bea4bf2f10ebdf300bc4920827a3325a5c26498efb3e6a4af5b016a SHA512 fd8cc75c70814afc427fbccbe8a1389773737ee664a42a43bb2fb7e7ff667fac4680d233c751ee15b03e41b60ba270b3cf48b1a766420468e4a7c974e4c0158c
diff --git a/dev-python/rope/rope-1.10.0.ebuild b/dev-python/rope/rope-1.10.0.ebuild
new file mode 100644
index 000000000000..c2536d79323e
--- /dev/null
+++ b/dev-python/rope/rope-1.10.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytoolconfig-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # our venv style confuses this comparison
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_source_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_compiled
+)