summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-24 16:45:21 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-24 17:22:26 +0100
commit73d657da404e603850ec4771cdf3e71bf6633edd (patch)
tree487740270b38894650594252a15be4057300adeb /dev-python/rope
parentmedia-sound/openmpt123: Bump to 0.7.4, drop old 0.7.3 (diff)
downloadgentoo-73d657da404e603850ec4771cdf3e71bf6633edd.tar.gz
gentoo-73d657da404e603850ec4771cdf3e71bf6633edd.tar.bz2
gentoo-73d657da404e603850ec4771cdf3e71bf6633edd.zip
dev-python/rope: Bump to 1.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/rope-1.13.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index 0e6010157daf..966128933a4f 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1 +1,2 @@
DIST rope-1.12.0.tar.gz 288737 BLAKE2B d6ad6b549969f52c8a4a84bedd3c652e683157ce79a42677b3b475b7001e802d68c12c91d8d915eb07f562ce84d42d046d83852404aab9ee309c616640364e77 SHA512 36b948b0bb212faeb77fd93bfc0b8586c41ca260ec01cddafe4599a28630b16d74c7eeacc82755a7d9ff7d2497e2d4fa2bfddd270c3f6194c50430f884c1e6e8
+DIST rope-1.13.0.tar.gz 294457 BLAKE2B 6d859f9a5d09734ef90398671a3ef3c8564f2a8b1d03a064d22161ac7deeceefb38849cd6940a53f61f20199c27edc5ef5e88d59336cfd69f4da22685c705356 SHA512 2f150d8b56165dd3cffc3f41d94394b5f44d7d6274859d7b460c6e61b99cb9d9630f3540940fa97bcd1238fa8a799cf9c80f2d9b5b7fd6a690cebabadf775db4
diff --git a/dev-python/rope/rope-1.13.0.ebuild b/dev-python/rope/rope-1.13.0.ebuild
new file mode 100644
index 000000000000..83b0ee21cceb
--- /dev/null
+++ b/dev-python/rope/rope-1.13.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytoolconfig-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # our venv style confuses this comparison
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_source_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_compiled
+ # TODO
+ ropetest/contrib/autoimport/autoimporttest.py::TestQueryUsesIndexes::test_search_by_name_like_uses_index
+ ropetest/contrib/autoimport/autoimporttest.py::TestQueryUsesIndexes::test_search_module_like_uses_index
+)