summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-17 05:18:05 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-17 06:07:42 +0100
commit64b456ad3b47fc424bbfa31120302f1188fa5fbf (patch)
treeb7b9b40d70134cf166da94f0fc26c4835d3f3e7f /dev-python/rope
parentwww-client/firefox-bin: drop 108.0.2 (diff)
downloadgentoo-64b456ad3b47fc424bbfa31120302f1188fa5fbf.tar.gz
gentoo-64b456ad3b47fc424bbfa31120302f1188fa5fbf.tar.bz2
gentoo-64b456ad3b47fc424bbfa31120302f1188fa5fbf.zip
dev-python/rope: Bump to 1.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/rope-1.7.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index 45edde1fdb44..909c11037da5 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1 +1,2 @@
DIST rope-1.6.0.tar.gz 289325 BLAKE2B fc7fc37a93f6d011f7e5eab5d2a28e3eab1767839cba4bce2b665c7972d6485eb3693e5977abfd36025415bc898fb4985affb7ac757c8457840a5de3946df77d SHA512 f610eb71c20533907aeea86c3ec5101401cf8136aba4221b2d64db3b0db16d4d7d1ec081c6d4929d6534ed51d4c01761af8d2ffddb6b69b4a9cc4921d240d745
+DIST rope-1.7.0.tar.gz 295362 BLAKE2B a81d6600441cf9dfe12be0a15113988ac8ec3dcd00c593085b9d749001b0785a5bceedc0fa8bbaeaaeb0142d623a432ef7d6e24874fab7a37179f131a26e6a6c SHA512 13cc3a2041c58c142892d1c9e5105ecdaa672e012364a5d4ccf82dbf5110fe0b6f0362b3a0309e9e6b72ab1d267dfc58eae8f3af3a8756f0356a6aff06c09abd
diff --git a/dev-python/rope/rope-1.7.0.ebuild b/dev-python/rope/rope-1.7.0.ebuild
new file mode 100644
index 000000000000..827ea89bc22c
--- /dev/null
+++ b/dev-python/rope/rope-1.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytoolconfig-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # our venv style confuses this comparison
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_source_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_compiled
+)