summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-05 20:19:47 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-05 20:30:10 +0300
commit0bc5f175eeaa1cb628e602c42f236411ebc9f048 (patch)
tree0bbba470233ac8b5fe5a066f2202e0aa417d784c /dev-python/rope
parentsys-libs/binutils-libs: drop 2.39-r4, 2.40-r1, 2.40-r2 (diff)
downloadgentoo-0bc5f175eeaa1cb628e602c42f236411ebc9f048.tar.gz
gentoo-0bc5f175eeaa1cb628e602c42f236411ebc9f048.tar.bz2
gentoo-0bc5f175eeaa1cb628e602c42f236411ebc9f048.zip
dev-python/rope: add 1.8.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/rope-1.8.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index cb576b061e6f..ccd7851072b2 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1 +1,2 @@
DIST rope-1.7.0.tar.gz 295362 BLAKE2B a81d6600441cf9dfe12be0a15113988ac8ec3dcd00c593085b9d749001b0785a5bceedc0fa8bbaeaaeb0142d623a432ef7d6e24874fab7a37179f131a26e6a6c SHA512 13cc3a2041c58c142892d1c9e5105ecdaa672e012364a5d4ccf82dbf5110fe0b6f0362b3a0309e9e6b72ab1d267dfc58eae8f3af3a8756f0356a6aff06c09abd
+DIST rope-1.8.0.tar.gz 297235 BLAKE2B e9849b75b3ec640201b30318863066b969b5ebde98522c3c09f70bcc344bce5f604601bd155ed0ce6fb3eebb392ea3669f77fb2da21c11078e1041ae13464fd8 SHA512 2fa8e56d6d7fd0a15acb16a1fe27db89d9c2dd6f93fabd448509a112a6ef7f3dfdd4d3d544cf1218149c7a7fa1db9908b107b6eae6e89299f32c0d1586ceaf4e
diff --git a/dev-python/rope/rope-1.8.0.ebuild b/dev-python/rope/rope-1.8.0.ebuild
new file mode 100644
index 000000000000..d3ca80b1d3ec
--- /dev/null
+++ b/dev-python/rope/rope-1.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytoolconfig-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # our venv style confuses this comparison
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_source_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_compiled
+)