summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-02 08:16:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-02 08:42:27 +0200
commitc87e615310f625ab0d31d91b669a2c8c978f3f05 (patch)
treeb55df38fe3ee113d91166aabdc635096613c6de4 /dev-python/readthedocs-sphinx-ext
parentdev-python/nptyping: Bump to 2.1.1 (diff)
downloadgentoo-c87e615310f625ab0d31d91b669a2c8c978f3f05.tar.gz
gentoo-c87e615310f625ab0d31d91b669a2c8c978f3f05.tar.bz2
gentoo-c87e615310f625ab0d31d91b669a2c8c978f3f05.zip
dev-python/readthedocs-sphinx-ext: Bump to 2.1.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/readthedocs-sphinx-ext')
-rw-r--r--dev-python/readthedocs-sphinx-ext/Manifest1
-rw-r--r--dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.8.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/readthedocs-sphinx-ext/Manifest b/dev-python/readthedocs-sphinx-ext/Manifest
index ff88b6c758e9..e55b2094ba67 100644
--- a/dev-python/readthedocs-sphinx-ext/Manifest
+++ b/dev-python/readthedocs-sphinx-ext/Manifest
@@ -1,3 +1,4 @@
DIST readthedocs-sphinx-ext-2.1.5.tar.gz 12351 BLAKE2B 5cb3e821b04dabb492cac194ec3be4cdf5874811d8e57556c653611d4a1e2d57a38c00492662d1530f25f15a011834a7966af4c58b9f8f8fe71559753cf3d79d SHA512 0d2960ca55bf9be4faad0a8aa9cdcde74aaa69529b98be6059377ae037ce447d5919617fd8d4afb85ece6dc7f2693426e1a5574049025859e300211f7a5802fb
DIST readthedocs-sphinx-ext-2.1.6.tar.gz 12343 BLAKE2B bbc1b80e18c1023ef498b7508b1acc400279042ec224bb5d51e60eef586ca2a95a740cddf4bf4a2f165c7012a521cff01196286ca21a51c5a0ffde03e2bdb70f SHA512 f9a4cffbd8939162c2a439e08f5f52a2313f00f42b3efecd4fa1431aa85aac205afcd04b5ecda089a4a239ef77e4f885a7cba9884219229b7c576f173bc52b14
DIST readthedocs-sphinx-ext-2.1.7.tar.gz 12351 BLAKE2B 4646016330591dd32d7065d3805f6158aa57aaee44848e91ac7550149a151ed32ff0d6945165c0112e39cd211126b773713ef8d8f669156c36e9f70a24afbd1b SHA512 bbf4a0e266248374198eedeb84b9866cb69e7a8531bbdbb6ad765f2d7013aa1b0b51cc57205b59be04592959b026c71e887035e663b7eb2c0ed6769272542162
+DIST readthedocs-sphinx-ext-2.1.8.tar.gz 12359 BLAKE2B 9a1c66725d4d48b6511462c5eea5d87fb28962444f8ff921208579bb2118571da34d2697d2bc91dc1ff71a2e3b7cb1c5b20021bc2f053fffd34f4eb0ae99d387 SHA512 2766c0ce69d7d3738cd454c8d3e733542849e6cd96414e1714f337defb62f9260c89a00c9bcc26582e15ce1629d61c48441826c2af84d92da0a6a5b65f474891
diff --git a/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.8.ebuild b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.8.ebuild
new file mode 100644
index 000000000000..e81bce103439
--- /dev/null
+++ b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Code specific for Read the Docs and Sphinx"
+HOMEPAGE="
+ https://github.com/readthedocs/readthedocs-sphinx-ext/
+ https://pypi.org/project/readthedocs-sphinx-ext/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jinja-2.9[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+# unittest should be sufficient but tests are very verbose, so pytest's
+# output capture is most welcome
+distutils_enable_tests pytest