summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-27 17:30:37 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-27 17:52:47 +0200
commit2700e1734d73a0b33db09c2e8e7a4509a60becf2 (patch)
tree3f84eb3120c3370cab2dc2c8ea71f57532ee2a6c /dev-python/pytest-trio
parentsys-apps/systemd: add 249_rc2, drop 249_rc1-r1 (diff)
downloadgentoo-2700e1734d73a0b33db09c2e8e7a4509a60becf2.tar.gz
gentoo-2700e1734d73a0b33db09c2e8e7a4509a60becf2.tar.bz2
gentoo-2700e1734d73a0b33db09c2e8e7a4509a60becf2.zip
dev-python/pytest-trio: import from ::guru
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pytest-trio')
-rw-r--r--dev-python/pytest-trio/Manifest1
-rw-r--r--dev-python/pytest-trio/metadata.xml13
-rw-r--r--dev-python/pytest-trio/pytest-trio-0.7.0.ebuild43
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pytest-trio/Manifest b/dev-python/pytest-trio/Manifest
new file mode 100644
index 000000000000..e39be86a7c57
--- /dev/null
+++ b/dev-python/pytest-trio/Manifest
@@ -0,0 +1 @@
+DIST pytest-trio-0.7.0.tar.gz 47784 BLAKE2B 59b28df45e87804e0b6eb557a0cf259fdc3636cc7a03d78248fb814d55904ed01d00a530b194b2bfe93ccfb9de528d70a372faf1f6db24531c230319122db2e5 SHA512 547036c94f33cf8e755c88d608c5fddfa5c583fdaa7e604598d470e250a006c571702a81bac4f273b74450a8c10e4be404bad74d4104403fe1c9c70e872dff53
diff --git a/dev-python/pytest-trio/metadata.xml b/dev-python/pytest-trio/metadata.xml
new file mode 100644
index 000000000000..e724d1bb8497
--- /dev/null
+++ b/dev-python/pytest-trio/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">python-trio/pytest-trio</remote-id>
+ <remote-id type="pypi">pytest-trio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild b/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
new file mode 100644
index 000000000000..5f6946b22be2
--- /dev/null
+++ b/dev-python/pytest-trio/pytest-trio-0.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a pytest plugin to help you test projects that use Trio"
+HOMEPAGE="
+ https://github.com/python-trio/pytest-trio
+ https://pypi.org/project/pytest-trio/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/async_generator-1.9[${PYTHON_USEDEP}]
+ dev-python/outcome[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.15[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests --install pytest
+distutils_enable_sphinx docs/source \
+ dev-python/attrs \
+ dev-python/sphinx_rtd_theme \
+ dev-python/sphinxcontrib-trio
+
+python_prepare_all() {
+ # Defining 'pytest_plugins' in a non-top-level conftest is no longer supported:
+ mv pytest_trio/_tests/conftest.py conftest.py || die
+ distutils-r1_python_prepare_all
+}