summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-23 06:54:44 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-23 07:07:13 +0200
commitfa98bf071eb8052a416a5ffe01ef342a578ccf89 (patch)
treeee572686c813071e5afc4a858b0e567164726f57 /dev-python/pytest-console-scripts
parentdev-python/mkdocs-git-authors-plugin: Bump to 0.7.1 (diff)
downloadgentoo-fa98bf071eb8052a416a5ffe01ef342a578ccf89.tar.gz
gentoo-fa98bf071eb8052a416a5ffe01ef342a578ccf89.tar.bz2
gentoo-fa98bf071eb8052a416a5ffe01ef342a578ccf89.zip
dev-python/pytest-console-scripts: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-console-scripts')
-rw-r--r--dev-python/pytest-console-scripts/Manifest1
-rw-r--r--dev-python/pytest-console-scripts/pytest-console-scripts-1.4.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-console-scripts/Manifest b/dev-python/pytest-console-scripts/Manifest
index 90c710e59c7f..c4475938be5f 100644
--- a/dev-python/pytest-console-scripts/Manifest
+++ b/dev-python/pytest-console-scripts/Manifest
@@ -1 +1,2 @@
DIST pytest-console-scripts-1.3.1.tar.gz 14238 BLAKE2B 2c00af468d19500078f48ca38d20430ed426e66b2277b7ad233356969d2a72d51cf60e90a46ae7808e6d33172fa053cc34d45b1f618d866dd14e917e6b225935 SHA512 344e9379976d9a7541f9683f7646b47f7fc25d2ab8d941351811ada7fddd77497cc24f4bc6a6d5ab9388dd5b289ed125bcbfad869009fb3b80aaaa1b951d656d
+DIST pytest-console-scripts-1.4.0.tar.gz 19718 BLAKE2B 51508bdd60c3100bd74611ab640e6346207d2310d60099af5ce5d5d056cb379e250e49e5cd78c65f276c43797405471c1478896543b89e9415577acf5c6bc6bc SHA512 ccfc9032a05934fb12b5f29052f5335fc37c90f5bbbc2a31b0bd422c3a04a1cc23fbc23fb3537415905ac1dba9d6ea916e2ae0b659330189f0184a8e70f4eff1
diff --git a/dev-python/pytest-console-scripts/pytest-console-scripts-1.4.0.ebuild b/dev-python/pytest-console-scripts/pytest-console-scripts-1.4.0.ebuild
new file mode 100644
index 000000000000..567b5764c6c4
--- /dev/null
+++ b/dev-python/pytest-console-scripts/pytest-console-scripts-1.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for testing console scripts"
+HOMEPAGE="https://github.com/kvas-it/pytest-console-scripts"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local script="${BUILD_DIR}/install${EPREFIX}/usr/bin/pytest"
+ cat > "${script}" <<-EOF
+ #!/usr/bin/env python
+ import pytest
+ import sys
+ sys.exit(pytest.console_main())
+ EOF
+ chmod +x "${script}" || die
+ epytest -x
+ rm "${script}" || die
+}