summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-01 21:41:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-01 22:41:49 +0300
commit1d1352bf7c6ca45e13b6a99759f4f3e765b5ce06 (patch)
tree7a868c30f40b09e7b2443b8617211b4b0c38d138 /dev-python/pyphen
parentapp-text/unpaper: Stabilize 7.0.0 x86, #867910 (diff)
downloadgentoo-1d1352bf7c6ca45e13b6a99759f4f3e765b5ce06.tar.gz
gentoo-1d1352bf7c6ca45e13b6a99759f4f3e765b5ce06.tar.bz2
gentoo-1d1352bf7c6ca45e13b6a99759f4f3e765b5ce06.zip
dev-python/pyphen: add 0.13.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pyphen')
-rw-r--r--dev-python/pyphen/Manifest1
-rw-r--r--dev-python/pyphen/pyphen-0.13.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pyphen/Manifest b/dev-python/pyphen/Manifest
index f90e01c84bcd..cb07a67ab4d0 100644
--- a/dev-python/pyphen/Manifest
+++ b/dev-python/pyphen/Manifest
@@ -1 +1,2 @@
DIST Pyphen-0.12.0.tar.gz 1969022 BLAKE2B 9b7f6712a2085507684ddde52401a75b05d0a13a530572f0f08b9143168a8ea61a5ee73983606b19f88ff23f3c5344aa87722c3986291c7349f82e95dd3b1f19 SHA512 abecf0773f59b7a757b47c6512f1bf8e98f4709b285f04cf235c085ab4767eb95deab8ede4b792d6f4a6156d47287f9f712cb658939ed5afc475644e282adbd3
+DIST pyphen-0.13.0.gh.tar.gz 1976723 BLAKE2B 2a2934cabf13f1b77477d131622cd2f03c342557bdfe3b2f7cfbbf31c4538850e021e074798d80300f87b2557f87cbf3bbeafd01da03b38a7036609e61e140ec SHA512 67897cec0b213a755af53ac21c61ddc1ac573a724658543174c3f88adb5f3db367fecf3afb1e7035c0d5b87e624daa2fe7650cb6e44c63d3b9ef6962bbc5d9e2
diff --git a/dev-python/pyphen/pyphen-0.13.0.ebuild b/dev-python/pyphen/pyphen-0.13.0.ebuild
new file mode 100644
index 000000000000..77020f6adc62
--- /dev/null
+++ b/dev-python/pyphen/pyphen-0.13.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
+HOMEPAGE="https://github.com/Kozea/Pyphen"
+SRC_URI="https://github.com/Kozea/Pyphen/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # avoid dep on extra plugins
+ sed -e '/addopts/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}