summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-13 12:59:00 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-13 12:59:00 +0200
commite9e9dd9175fdbb9c02944b47a762111ac3a8d599 (patch)
tree52bd1ec693807d9cb8e423fc298484cd849d43cf /dev-python/pyjwt
parentsys-cluster/ceph: Remove old (diff)
downloadgentoo-e9e9dd9175fdbb9c02944b47a762111ac3a8d599.tar.gz
gentoo-e9e9dd9175fdbb9c02944b47a762111ac3a8d599.tar.bz2
gentoo-e9e9dd9175fdbb9c02944b47a762111ac3a8d599.zip
dev-python/pyjwt: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyjwt')
-rw-r--r--dev-python/pyjwt/Manifest2
-rw-r--r--dev-python/pyjwt/files/pyjwt-1.7.1-ecdsa-fix.patch27
-rw-r--r--dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild55
-rw-r--r--dev-python/pyjwt/pyjwt-2.3.0.ebuild29
4 files changed, 0 insertions, 113 deletions
diff --git a/dev-python/pyjwt/Manifest b/dev-python/pyjwt/Manifest
index 5488502fb3b8..dca287789b78 100644
--- a/dev-python/pyjwt/Manifest
+++ b/dev-python/pyjwt/Manifest
@@ -1,3 +1 @@
-DIST PyJWT-1.7.1.tar.gz 41979 BLAKE2B 5604b309838b2dfb2f95e18e291c43703954664aa8acb7439072f002c1c8a1e49ff2c21d907be77a4d2f86e695ec71970d550aad2541252ac85bd7133e300b28 SHA512 70cd38127b6848933992c8b88303725ef71bfb430ad42eb63247e549b0bdab2a194137349d43ab02a1c97212dbc89f447ee3f0c5403dd14632b8b4b6b9235fc4
-DIST PyJWT-2.3.0.tar.gz 62279 BLAKE2B 0f4cea0cee2461e5f829b2bba40fb6d2646d5bccaa8e6b2d26ba7379386a64dc9f5204ea607edec98fc0102facf3cc5595e5e97523e9a567e0cf0b072542a3f5 SHA512 c6a1d8c3ce87d2122aa4ce4e19c5d2683aeffae6fb29b20fa17e2dfb1a07faf721beb8ca390d3acdeb85a1476025ca5af4fcdb1019f84c8c1bf229246a7aafe3
DIST PyJWT-2.4.0.tar.gz 66327 BLAKE2B bc78ceebe3fedd4216420c34034de96dc6af488b4b50d20a03073753cfe94d059cda3e118f79cc3718253f56bb977b5b86543d1cd1ab7346a4095d0c2c6855b2 SHA512 6c60afe62f9341c0fd889be227cd9e44260bc88696a93d0c3398547e159001f04e402d207d2230641f0f3d37cfd7e6f9e50a42dadfb011d7087c32a864c792a4
diff --git a/dev-python/pyjwt/files/pyjwt-1.7.1-ecdsa-fix.patch b/dev-python/pyjwt/files/pyjwt-1.7.1-ecdsa-fix.patch
deleted file mode 100644
index ebd9236c7994..000000000000
--- a/dev-python/pyjwt/files/pyjwt-1.7.1-ecdsa-fix.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 36a3f9bd0cc7029e5150b1931efbd62da975e8b9 Mon Sep 17 00:00:00 2001
-From: StefanBruens <stefan.bruens@rwth-aachen.de>
-Date: Mon, 21 Oct 2019 02:07:19 +0200
-Subject: [PATCH] Catch BadSignatureError raised by ecdsa 0.13.3 on
- verification errors (#448)
-
-The new ecdsa no longer uses AssertionError when the signature is too long.
-This happens in the test suite, where "123" is appended to the signature.
-
-Fixes #447
----
- jwt/contrib/algorithms/py_ecdsa.py | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/jwt/contrib/algorithms/py_ecdsa.py b/jwt/contrib/algorithms/py_ecdsa.py
-index bf0dea5..f1170a6 100644
---- a/jwt/contrib/algorithms/py_ecdsa.py
-+++ b/jwt/contrib/algorithms/py_ecdsa.py
-@@ -56,5 +56,7 @@ def verify(self, msg, key, sig):
- try:
- return key.verify(sig, msg, hashfunc=self.hash_alg,
- sigdecode=ecdsa.util.sigdecode_string)
-- except AssertionError:
-+ # ecdsa <= 0.13.2 raises AssertionError on too long signatures,
-+ # ecdsa >= 0.13.3 raises BadSignatureError for verification errors.
-+ except (AssertionError, ecdsa.BadSignatureError):
- return False
diff --git a/dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild b/dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild
deleted file mode 100644
index 1849483dffc3..000000000000
--- a/dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
-inherit distutils-r1 optfeature
-
-MY_PN="PyJWT"
-DESCRIPTION="JSON Web Token implementation in Python"
-HOMEPAGE="https://github.com/progrium/pyjwt https://pypi.org/project/PyJWT/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}"/${MY_PN}-${PV}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND=""
-DEPEND="
- test? (
- >=dev-python/cryptography-1.4.0[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- find . -name '__pycache__' -prune -exec rm -rf {} + || die
- find . -name '*.pyc' -delete || die
-
- # enables coverage, we don't need that
- rm setup.cfg || die
- # kill tests using pycrypto that break with pycryptodome
- sed -i -e '/has_pycrypto/s:True:False:' \
- tests/contrib/test_algorithms.py || die
-
- local PATCHES=(
- "${FILESDIR}"/pyjwt-1.7.1-ecdsa-fix.patch
- )
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
-
-pkg_postinst() {
- optfeature "cryptography" dev-python/cryptography
- optfeature "flake8" dev-python/flake8{,-import-order}
-
- ewarn "flake8 feature requires 'pep8-naming' which is not packaged yet"
-}
diff --git a/dev-python/pyjwt/pyjwt-2.3.0.ebuild b/dev-python/pyjwt/pyjwt-2.3.0.ebuild
deleted file mode 100644
index 6b5ead763d7d..000000000000
--- a/dev-python/pyjwt/pyjwt-2.3.0.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1 optfeature
-
-MY_PN="PyJWT"
-DESCRIPTION="JSON Web Token implementation in Python"
-HOMEPAGE="https://github.com/jpadilla/pyjwt/ https://pypi.org/project/PyJWT/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}"/${MY_PN}-${PV}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc ~ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="!dev-python/python-jwt"
-BDEPEND="
- test? (
- >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-pkg_postinst() {
- optfeature "cryptography" dev-python/cryptography
-}