summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-13 07:56:24 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-13 08:15:28 +0200
commit56f59c59ce272031e71989092da81e558c5f74aa (patch)
tree57ec0d4024f195d3083e2d25dc6a7adec8432545 /dev-python/pyjwt
parentdev-python/jwcrypto: Bump to 1.3.0 (diff)
downloadgentoo-56f59c59ce272031e71989092da81e558c5f74aa.tar.gz
gentoo-56f59c59ce272031e71989092da81e558c5f74aa.tar.bz2
gentoo-56f59c59ce272031e71989092da81e558c5f74aa.zip
dev-python/pyjwt: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyjwt')
-rw-r--r--dev-python/pyjwt/Manifest1
-rw-r--r--dev-python/pyjwt/pyjwt-2.4.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyjwt/Manifest b/dev-python/pyjwt/Manifest
index 83ba313e1e3c..5488502fb3b8 100644
--- a/dev-python/pyjwt/Manifest
+++ b/dev-python/pyjwt/Manifest
@@ -1,2 +1,3 @@
DIST PyJWT-1.7.1.tar.gz 41979 BLAKE2B 5604b309838b2dfb2f95e18e291c43703954664aa8acb7439072f002c1c8a1e49ff2c21d907be77a4d2f86e695ec71970d550aad2541252ac85bd7133e300b28 SHA512 70cd38127b6848933992c8b88303725ef71bfb430ad42eb63247e549b0bdab2a194137349d43ab02a1c97212dbc89f447ee3f0c5403dd14632b8b4b6b9235fc4
DIST PyJWT-2.3.0.tar.gz 62279 BLAKE2B 0f4cea0cee2461e5f829b2bba40fb6d2646d5bccaa8e6b2d26ba7379386a64dc9f5204ea607edec98fc0102facf3cc5595e5e97523e9a567e0cf0b072542a3f5 SHA512 c6a1d8c3ce87d2122aa4ce4e19c5d2683aeffae6fb29b20fa17e2dfb1a07faf721beb8ca390d3acdeb85a1476025ca5af4fcdb1019f84c8c1bf229246a7aafe3
+DIST PyJWT-2.4.0.tar.gz 66327 BLAKE2B bc78ceebe3fedd4216420c34034de96dc6af488b4b50d20a03073753cfe94d059cda3e118f79cc3718253f56bb977b5b86543d1cd1ab7346a4095d0c2c6855b2 SHA512 6c60afe62f9341c0fd889be227cd9e44260bc88696a93d0c3398547e159001f04e402d207d2230641f0f3d37cfd7e6f9e50a42dadfb011d7087c32a864c792a4
diff --git a/dev-python/pyjwt/pyjwt-2.4.0.ebuild b/dev-python/pyjwt/pyjwt-2.4.0.ebuild
new file mode 100644
index 000000000000..979dd67cc701
--- /dev/null
+++ b/dev-python/pyjwt/pyjwt-2.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+MY_PN="PyJWT"
+DESCRIPTION="JSON Web Token implementation in Python"
+HOMEPAGE="
+ https://github.com/jpadilla/pyjwt/
+ https://pypi.org/project/PyJWT/
+"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S=${WORKDIR}/${MY_PN}-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ !dev-python/python-jwt
+"
+BDEPEND="
+ test? (
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "cryptography" dev-python/cryptography
+}