summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-27 20:27:14 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-27 20:43:13 +0100
commit8389d918cfd74bf266200c226144744baf873bd8 (patch)
treedefe216aec25706c5de8a2f11e69583234a8e07c /dev-python/pyclipper
parentdev-python/reportlab: Bump to 3.5.57 (diff)
downloadgentoo-8389d918cfd74bf266200c226144744baf873bd8.tar.gz
gentoo-8389d918cfd74bf266200c226144744baf873bd8.tar.bz2
gentoo-8389d918cfd74bf266200c226144744baf873bd8.zip
dev-python/pyclipper: Bump to 1.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyclipper')
-rw-r--r--dev-python/pyclipper/Manifest1
-rw-r--r--dev-python/pyclipper/pyclipper-1.2.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyclipper/Manifest b/dev-python/pyclipper/Manifest
index bd07145563bc..2b0c4ea3a1b0 100644
--- a/dev-python/pyclipper/Manifest
+++ b/dev-python/pyclipper/Manifest
@@ -1 +1,2 @@
DIST pyclipper-1.2.0.tar.gz 53504 BLAKE2B 611a86b4173838dc0c77ad765f1ab9d08e73b147936ec60fae63308d5bb0019b40479222b80565f3d3ba5337c1a436fa63306105bb3a698592160eb8b66f3014 SHA512 2b8966a695fd7916786ab7549f8c867aad1d4879f3d20b87d7a4b6e1fff8a36871a440795548e91256ff89e574c04be4390ffbd05bab6b0bb51441c7f8acf674
+DIST pyclipper-1.2.1.tar.gz 51862 BLAKE2B be59011d44ba4364e3e0d1d789c10f76635a5bc690dad8030104fa7965cc118e3529bf6505e5c4e743a8ff21e0d24129be716cd91e09b7521baa64359de364ab SHA512 0fc411bd8fa33fc3e5a71ec149b720b5c2f2e9a5e704d5e175b5930e0e073bacfd26b68e19c00802ab68e7a8946bdfcacae858e2d6d81b87d85b3747fa4a316b
diff --git a/dev-python/pyclipper/pyclipper-1.2.1.ebuild b/dev-python/pyclipper/pyclipper-1.2.1.ebuild
new file mode 100644
index 000000000000..3efd8d8de2fc
--- /dev/null
+++ b/dev-python/pyclipper/pyclipper-1.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Cython wrapper for the C++ translation of the Angus Johnson's Clipper library"
+HOMEPAGE="https://github.com/fonttools/pyclipper"
+SRC_URI="https://github.com/fonttools/pyclipper/archive/${PV/_p/.post}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P/_p/.post}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ export SETUPTOOLS_SCM_PRETEND_VERSION="${PV/_p/.post}"
+}