summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-05 13:15:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-05 13:15:23 +0200
commit6df8a9453c8051d423cdf8235dc65686388efc33 (patch)
treecb6118f69c708fbd27bacab652192ca7050a66d3 /dev-python/pyclipper
parentdev-python/kafka-python: Correct test dependencies (diff)
downloadgentoo-6df8a9453c8051d423cdf8235dc65686388efc33.tar.gz
gentoo-6df8a9453c8051d423cdf8235dc65686388efc33.tar.bz2
gentoo-6df8a9453c8051d423cdf8235dc65686388efc33.zip
dev-python/pyclipper: Backport unittest2 removal to 1.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyclipper')
-rw-r--r--dev-python/pyclipper/pyclipper-1.2.1.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/dev-python/pyclipper/pyclipper-1.2.1.ebuild b/dev-python/pyclipper/pyclipper-1.2.1.ebuild
index 949db123645f..776f9a4c727b 100644
--- a/dev-python/pyclipper/pyclipper-1.2.1.ebuild
+++ b/dev-python/pyclipper/pyclipper-1.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..9} )
inherit distutils-r1
DESCRIPTION="Cython wrapper for the C++ translation of the Angus Johnson's Clipper library"
@@ -19,14 +19,12 @@ IUSE=""
BDEPEND="
dev-python/cython[${PYTHON_USEDEP}]
dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- dev-python/unittest2[${PYTHON_USEDEP}]
- )
"
distutils_enable_tests pytest
src_prepare() {
+ sed -i -e 's:from unittest2:from unittest:' tests/test_pyclipper.py || die
distutils-r1_src_prepare
export SETUPTOOLS_SCM_PRETEND_VERSION="${PV/_p/.post}"
}