summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-10 16:46:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-10 17:33:42 +0200
commit369ac83bc2def14326d5f4699db021d95770b823 (patch)
tree1465d82584896a537ea4260f1e47e1be56654aea /dev-python/patsy
parentdev-libs/libfilezilla: run eautoreconf to handle patched configure.ac (diff)
downloadgentoo-369ac83bc2def14326d5f4699db021d95770b823.tar.gz
gentoo-369ac83bc2def14326d5f4699db021d95770b823.tar.bz2
gentoo-369ac83bc2def14326d5f4699db021d95770b823.zip
dev-python/patsy: Patch support for dev-python/numpy-2 in
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/patsy')
-rw-r--r--dev-python/patsy/files/patsy-0.5.6-np2.patch51
-rw-r--r--dev-python/patsy/patsy-0.5.6-r2.ebuild36
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/patsy/files/patsy-0.5.6-np2.patch b/dev-python/patsy/files/patsy-0.5.6-np2.patch
new file mode 100644
index 000000000000..169eadb851fe
--- /dev/null
+++ b/dev-python/patsy/files/patsy-0.5.6-np2.patch
@@ -0,0 +1,51 @@
+diff --git a/patsy/highlevel.py b/patsy/highlevel.py
+index 78d2942..298739d 100644
+--- a/patsy/highlevel.py
++++ b/patsy/highlevel.py
+@@ -178,7 +178,7 @@ def _do_highlevel_design(formula_like, data, eval_env,
+ else:
+ # subok=True is necessary here to allow DesignMatrixes to pass
+ # through
+- (lhs, rhs) = (None, asarray_or_pandas(formula_like, subok=True))
++ (lhs, rhs) = (None, asarray_or_pandas(formula_like, subok=True, copy=None))
+ # some sort of explicit matrix or matrices were given. Currently we
+ # have them in one of these forms:
+ # -- an ndarray or subclass
+diff --git a/patsy/state.py b/patsy/state.py
+index 933c588..c489a4b 100644
+--- a/patsy/state.py
++++ b/patsy/state.py
+@@ -103,7 +103,7 @@ class Center(object):
+ pass
+
+ def transform(self, x):
+- x = asarray_or_pandas(x)
++ x = asarray_or_pandas(x, copy=None)
+ # This doesn't copy data unless our input is a DataFrame that has
+ # heterogeneous types. And in that case we're going to be munging the
+ # types anyway, so copying isn't a big deal.
+diff --git a/patsy/util.py b/patsy/util.py
+index 3116e11..7ac6f79 100644
+--- a/patsy/util.py
++++ b/patsy/util.py
+@@ -69,7 +69,7 @@ def asarray_or_pandas(a, copy=False, dtype=None, subok=False):
+
+ def test_asarray_or_pandas():
+ import warnings
+- assert type(asarray_or_pandas([1, 2, 3])) is np.ndarray
++ assert type(asarray_or_pandas([1, 2, 3], copy=True)) is np.ndarray
+ with warnings.catch_warnings() as w:
+ warnings.filterwarnings('ignore', 'the matrix subclass',
+ PendingDeprecationWarning)
+@@ -83,9 +83,9 @@ def test_asarray_or_pandas():
+ assert np.array_equal(a, a_copy)
+ a_copy[0] = 100
+ assert not np.array_equal(a, a_copy)
+- assert np.allclose(asarray_or_pandas([1, 2, 3], dtype=float),
++ assert np.allclose(asarray_or_pandas([1, 2, 3], dtype=float, copy=None),
+ [1.0, 2.0, 3.0])
+- assert asarray_or_pandas([1, 2, 3], dtype=float).dtype == np.dtype(float)
++ assert asarray_or_pandas([1, 2, 3], dtype=float, copy=None).dtype == np.dtype(float)
+ a_view = asarray_or_pandas(a, dtype=a.dtype)
+ a_view[0] = 99
+ assert a[0] == 99
diff --git a/dev-python/patsy/patsy-0.5.6-r2.ebuild b/dev-python/patsy/patsy-0.5.6-r2.ebuild
new file mode 100644
index 000000000000..4362947695b4
--- /dev/null
+++ b/dev-python/patsy/patsy-0.5.6-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module to describe statistical models and design matrices"
+HOMEPAGE="
+ https://patsy.readthedocs.io/en/latest/index.html
+ https://github.com/pydata/patsy/
+ https://pypi.org/project/patsy/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !hppa? (
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/pydata/patsy/issues/210
+ # ([probably] non-upstreamable hack)
+ "${FILESDIR}/${P}-np2.patch"
+)