summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-16 17:31:12 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-16 17:31:12 +0100
commita0128f29a0cac2fd10c7cda3f741a5931ee7dc37 (patch)
tree6773ce01a4851bbd54c56022d2f279e49c6d97da /dev-python/openapi-core
parentdev-python/Nuitka: Remove old (diff)
downloadgentoo-a0128f29a0cac2fd10c7cda3f741a5931ee7dc37.tar.gz
gentoo-a0128f29a0cac2fd10c7cda3f741a5931ee7dc37.tar.bz2
gentoo-a0128f29a0cac2fd10c7cda3f741a5931ee7dc37.zip
dev-python/openapi-core: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/openapi-core')
-rw-r--r--dev-python/openapi-core/Manifest1
-rw-r--r--dev-python/openapi-core/openapi-core-0.16.5.ebuild68
2 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/openapi-core/Manifest b/dev-python/openapi-core/Manifest
index 8243379b8dff..487675f4c66a 100644
--- a/dev-python/openapi-core/Manifest
+++ b/dev-python/openapi-core/Manifest
@@ -1,3 +1,2 @@
-DIST openapi-core-0.16.5.gh.tar.gz 104046 BLAKE2B 7dcda69b6d548a0df8c7727b184c7f7ec6d645e14ab4b4a256f188c6cc4ae9e351bc06ae03770782d81a11dfb5ebc08c20daabbd2151cfe62f84b05f80a47a16 SHA512 59db6d39a950079739b2df4114f26d85be55dc1f42d1661e8e6c17cf878cd8167f29ba4d3b6f40e06e85bb144c68286cb50adf4403091461798144cac05d5bc0
DIST openapi-core-0.16.6.gh.tar.gz 104008 BLAKE2B bb1bdac98dfc5aef0961624488074363568f53a6c44cb0730be0d103d891d24bed86659f640e0d07da4072edc233c904c0ddcfd9e8b3960ace1af078c0d745e5 SHA512 556636a4698dcd7db6c656333849077abacdac1a440fe58210ad8f02c1f0220e46dea29962346dfb3f89d164ebc986ec750c184840be9a34a5e1dd98fbf8ef98
DIST openapi-core-0.17.0.gh.tar.gz 129743 BLAKE2B 34b64f2c956218377d37c5f9e382aa503d50556d2a9ff292355831a39ff9632942b3dd6074cf91ba6cdb2fd93e12e4b3700232e720c71e814fde27f08052bb5a SHA512 6c284cbc8656b319291d81b73c3b714e1b9d8f85bbdf4b4636f8adcd0e47e59147f96a9cf117a6fcd49b7eeea4bbdbee28e3b60019add652e527c6af554d1cb7
diff --git a/dev-python/openapi-core/openapi-core-0.16.5.ebuild b/dev-python/openapi-core/openapi-core-0.16.5.ebuild
deleted file mode 100644
index 5f16bc813f6d..000000000000
--- a/dev-python/openapi-core/openapi-core-0.16.5.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Client-side and server-side support for the OpenAPI Specification v3"
-HOMEPAGE="
- https://github.com/p1c2u/openapi-core/
- https://pypi.org/project/openapi-core/
-"
-SRC_URI="
- https://github.com/p1c2u/openapi-core/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/pathable-0.4.0[${PYTHON_USEDEP}]
- dev-python/isodate[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-spec-0.1.1[${PYTHON_USEDEP}]
- dev-python/more-itertools[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- <dev-python/openapi-schema-validator-0.5[${PYTHON_USEDEP}]
- >=dev-python/openapi-schema-validator-0.3[${PYTHON_USEDEP}]
- <dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
- >=dev-python/openapi-spec-validator-0.5[${PYTHON_USEDEP}]
- dev-python/werkzeug[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/asgiref[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/httpx-0.23.0[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- >=dev-python/starlette-0.21.0[${PYTHON_USEDEP}]
- dev-python/strict-rfc3339[${PYTHON_USEDEP}]
- dev-python/webob[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # falcon is not packaged
- tests/integration/contrib/falcon
-
- # TODO: these tests fail to collect
- tests/integration/validation/test_security_override.py
- tests/integration/validation/test_read_only_write_only.py
-
- # unhappy about modern django
- tests/integration/contrib/django/test_django_project.py
- tests/unit/contrib/django/test_django.py
-)
-
-src_prepare() {
- sed -i -e '/--cov/d' pyproject.toml || die
- distutils-r1_src_prepare
-}