summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-08 16:40:53 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-08 16:40:53 +0200
commit947e3b1a93f8497238a99a53f659d02154524c42 (patch)
tree966fdc59aa6966618f07d32aa284712974ffe6a7 /dev-python/littleutils
parentdev-python/django-sortedm2m: PEP517 (diff)
downloadgentoo-947e3b1a93f8497238a99a53f659d02154524c42.tar.gz
gentoo-947e3b1a93f8497238a99a53f659d02154524c42.tar.bz2
gentoo-947e3b1a93f8497238a99a53f659d02154524c42.zip
dev-python/littleutils: PEP517, py3.12
Closes: https://bugs.gentoo.org/909919 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/littleutils')
-rw-r--r--dev-python/littleutils/littleutils-0.2.2-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/littleutils/littleutils-0.2.2-r1.ebuild b/dev-python/littleutils/littleutils-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..def0074b7ec3
--- /dev/null
+++ b/dev-python/littleutils/littleutils-0.2.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Small personal collection of Python utility functions"
+HOMEPAGE="
+ https://pypi.org/project/littleutils/
+ https://github.com/alexmojaki/littleutils/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+python_test() {
+ "${EPYTHON}" -m doctest -v littleutils/__init__.py ||
+ die "Tests fail with ${EPYTHON}"
+}