summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-22 20:22:48 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-22 20:25:17 +0200
commit56c8b15e015e7d81c5c04924dcebfcaa0ce245d7 (patch)
treeaba1427f0d98b654d66b465f54df340f866af62e /dev-python/libarchive-c
parentdev-python/asgiref: add 3.5.0 (diff)
downloadgentoo-56c8b15e015e7d81c5c04924dcebfcaa0ce245d7.tar.gz
gentoo-56c8b15e015e7d81c5c04924dcebfcaa0ce245d7.tar.bz2
gentoo-56c8b15e015e7d81c5c04924dcebfcaa0ce245d7.zip
dev-python/libarchive-c: add 4.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/libarchive-c')
-rw-r--r--dev-python/libarchive-c/Manifest1
-rw-r--r--dev-python/libarchive-c/libarchive-c-4.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/libarchive-c/Manifest b/dev-python/libarchive-c/Manifest
index 403767c9fef7..d7a9f3981b60 100644
--- a/dev-python/libarchive-c/Manifest
+++ b/dev-python/libarchive-c/Manifest
@@ -1 +1,2 @@
DIST libarchive-c-3.2.tar.gz 44896 BLAKE2B 9e984c8e23422ceb552d34d4560b2c8279e1c2d52ffedcc893af3a1a8420eb03b735058d2f8dbe542f3920d0f0bf53777f0679a238cc0368e8e680c44358a72c SHA512 d11a7da0e592b7fce5044b9ff2930e50004c15b166a76f7871b9d0d584cb6da5989c4ec79969439b00baffa564738af607cdf5e37141c6e879b8a76ae68c325c
+DIST libarchive-c-4.0.gh.tar.gz 47743 BLAKE2B c6246b35a9a389c6cd999b32412436f8134737a4cba1c0bf8a905e3ba6e1653c515956f43a580901dd4278cbc00b783ecfa7a4306f0fc7ca2d2666b3af500cb8 SHA512 787b049a5f06d7370369a6bb2d9ebab6e4e5eda0a4f839906e205a7e19a00f9f7e350d4c42e3434e345063dd0ea44e5b0b4c0524033b05a6d8f15758757c5c36
diff --git a/dev-python/libarchive-c/libarchive-c-4.0.ebuild b/dev-python/libarchive-c/libarchive-c-4.0.ebuild
new file mode 100644
index 000000000000..18351e6ff322
--- /dev/null
+++ b/dev-python/libarchive-c/libarchive-c-4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Python interface to libarchive"
+HOMEPAGE="https://github.com/Changaco/python-libarchive-c/ https://pypi.org/project/libarchive-c/"
+SRC_URI="
+ https://github.com/Changaco/python-libarchive-c/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}"/python-${P}
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="app-arch/libarchive"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest