summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-25 21:16:54 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-25 21:42:18 +0300
commit06984137d2ea8e6a0d0f063b2c1a19a5339f2f5b (patch)
treee94c304279a58d11a4ff9c0ca673f81ebbe61b5d /dev-python/jsonxs
parentdev-python/jsonrpclib: enable py3.11 (diff)
downloadgentoo-06984137d2ea8e6a0d0f063b2c1a19a5339f2f5b.tar.gz
gentoo-06984137d2ea8e6a0d0f063b2c1a19a5339f2f5b.tar.bz2
gentoo-06984137d2ea8e6a0d0f063b2c1a19a5339f2f5b.zip
dev-python/jsonxs: EAPI=8, Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/jsonxs')
-rw-r--r--dev-python/jsonxs/jsonxs-0.6-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/jsonxs/jsonxs-0.6-r1.ebuild b/dev-python/jsonxs/jsonxs-0.6-r1.ebuild
new file mode 100644
index 000000000000..932c4e73bc9f
--- /dev/null
+++ b/dev-python/jsonxs/jsonxs-0.6-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Get/set values in JSON and Python datastructures"
+HOMEPAGE="https://github.com/fboender/jsonxs"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" jsonxs/jsonxs.py -v || die "Tests failed with ${EPYTHON}"
+}