summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-12 05:11:53 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-12 05:11:53 +0100
commit2f55ad4bde6cc94604e8ce643ed2f6c5e7c23f73 (patch)
treefea7ce7e9e14bcf3572857725b6da3f59b95249f /dev-python/jsonpath-ng
parentdev-python/starlette: Bump to 0.35.1 (diff)
downloadgentoo-2f55ad4bde6cc94604e8ce643ed2f6c5e7c23f73.tar.gz
gentoo-2f55ad4bde6cc94604e8ce643ed2f6c5e7c23f73.tar.bz2
gentoo-2f55ad4bde6cc94604e8ce643ed2f6c5e7c23f73.zip
dev-python/jsonpath-ng: Bump to 1.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonpath-ng')
-rw-r--r--dev-python/jsonpath-ng/Manifest1
-rw-r--r--dev-python/jsonpath-ng/jsonpath-ng-1.6.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/jsonpath-ng/Manifest b/dev-python/jsonpath-ng/Manifest
index 739fddd28291..4c6c86029e4e 100644
--- a/dev-python/jsonpath-ng/Manifest
+++ b/dev-python/jsonpath-ng/Manifest
@@ -1 +1,2 @@
DIST jsonpath-ng-1.6.0.tar.gz 37132 BLAKE2B 5af13db8ab85482656d5c1501edfb2c61dc62a08a2c90a12a7ba7b141b538b5ebfca86c856b9f65ef1c1b82329eb0ed7db5c1890d881e4cb968cb6ca31ddeb6f SHA512 46eefe57330887143b98ef4deb97c5d7242f0cfbd923dffc17bd4147326ea4333c76df2451fbbb27933ada872628ad1ec04bdb9fc8e2c288c89bf37ec3783c43
+DIST jsonpath-ng-1.6.1.tar.gz 36024 BLAKE2B ed6b47974e55c8bb5e086249c24d847dc0e1719d6912c0097bf6bcc06ad096f54b99f9c7053c088bb2efae4c612a49364cae3b061593890508e408b6776e73fb SHA512 84f4ceb3b2e76665b56df6c6cd9bf8c155d3677cc6b4798531bb35e95a591e98186c7fa756d400cbbde4c62acc7da077d0fdf989f5101846fb74bba83dd4be58
diff --git a/dev-python/jsonpath-ng/jsonpath-ng-1.6.1.ebuild b/dev-python/jsonpath-ng/jsonpath-ng-1.6.1.ebuild
new file mode 100644
index 000000000000..263a95212698
--- /dev/null
+++ b/dev-python/jsonpath-ng/jsonpath-ng-1.6.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python JSONPath Next-Generation"
+HOMEPAGE="
+ https://github.com/h2non/jsonpath-ng/
+ https://pypi.org/project/jsonpath-ng/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/oslotest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest