summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-08 10:09:13 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-08 10:19:52 +0200
commit95ddfa5be4ca479badbe8380f156811c419149fd (patch)
tree0b4e459671ef990fc6270e92b261e32c0487551b /dev-python/jellyfish
parentdev-python/jellyfish: Remove dep on pytest-runner (diff)
downloadgentoo-95ddfa5be4ca479badbe8380f156811c419149fd.tar.gz
gentoo-95ddfa5be4ca479badbe8380f156811c419149fd.tar.bz2
gentoo-95ddfa5be4ca479badbe8380f156811c419149fd.zip
dev-python/jellyfish: Disable in-source builds
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jellyfish')
-rw-r--r--dev-python/jellyfish/jellyfish-0.7.2.ebuild10
1 files changed, 3 insertions, 7 deletions
diff --git a/dev-python/jellyfish/jellyfish-0.7.2.ebuild b/dev-python/jellyfish/jellyfish-0.7.2.ebuild
index d8d3b2e32dd4..8b4b1810513b 100644
--- a/dev-python/jellyfish/jellyfish-0.7.2.ebuild
+++ b/dev-python/jellyfish/jellyfish-0.7.2.ebuild
@@ -4,7 +4,6 @@
EAPI=7
PYTHON_COMPAT=( python3_{5,6,7} )
-DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
DESCRIPTION="Python module for doing approximate and phonetic matching of strings"
@@ -25,11 +24,6 @@ DEPEND="
)
"
-python_compile() {
- esetup.py build_ext --inplace
- esetup.py build
-}
-
python_compile_all() {
if use doc; then
esetup.py build_sphinx
@@ -38,5 +32,7 @@ python_compile_all() {
}
python_test() {
- py.test jellyfish/test.py || die "tests failed with ${EPYTHON}"
+ cp -r testdata "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+ pytest -vv lib/jellyfish/test.py || die "tests failed with ${EPYTHON}"
}