summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-11 04:22:39 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-11 04:22:39 +0100
commit963a0d4e4617fdb56c7c9d8809cec0a282ab8b09 (patch)
treea3feb91fadfd601d75098f334c5e3cd2d0581738 /dev-python/identify
parentdev-python/rfc3987: Add missing revbump (diff)
downloadgentoo-963a0d4e4617fdb56c7c9d8809cec0a282ab8b09.tar.gz
gentoo-963a0d4e4617fdb56c7c9d8809cec0a282ab8b09.tar.bz2
gentoo-963a0d4e4617fdb56c7c9d8809cec0a282ab8b09.zip
dev-python/identify: Bump to 2.5.34
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest1
-rw-r--r--dev-python/identify/identify-2.5.34.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index e3a0fb170fb9..3e5a9795b60d 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1 +1,2 @@
DIST identify-2.5.33.gh.tar.gz 101683 BLAKE2B 0b66bc611e5ba01029c2d8aa13146025eb68296793a148eafecc7584d3d68d77d8ebae67306e8fc64e7265ab673fa4852497f25b9ba73e895c61e4f4ec2997e2 SHA512 cb3cc2064814b6694122040dc1be31f09bbddaf988f15425717d5561f175b216e62f4449cff5d697a8d612a48513e97446973bba42f376cdcfad1d93d1e14cf7
+DIST identify-2.5.34.gh.tar.gz 101695 BLAKE2B 94522c083ce2584831bd61b6d7e34533f08ad3814ccde93b7340139bcc4dc05fa6384024e6f15cc33e480de06117d17a88d148044758658e7cb302bfab7d7366 SHA512 bf9fe2bdca46b1e9a7f1e4559178061bb5293d43b42962d17a08b6f9230c3d2d004b74ac3b1c825905fa77631533565b26c95a0fa99f2bb9a3320d2d4a5f67aa
diff --git a/dev-python/identify/identify-2.5.34.ebuild b/dev-python/identify/identify-2.5.34.ebuild
new file mode 100644
index 000000000000..0aa9daac20bc
--- /dev/null
+++ b/dev-python/identify/identify-2.5.34.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest