summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-01 05:11:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-01 05:21:58 +0200
commit74600b1719bd5ed24d8dc2f1f06e1ab9b02f8fb3 (patch)
tree9cd5b57875762f1dd5dbb9cbc6f212aa6843f966 /dev-python/identify
parentsys-fs/bcachefs-tools: convert helper scripts to symlinks (diff)
downloadgentoo-74600b1719bd5ed24d8dc2f1f06e1ab9b02f8fb3.tar.gz
gentoo-74600b1719bd5ed24d8dc2f1f06e1ab9b02f8fb3.tar.bz2
gentoo-74600b1719bd5ed24d8dc2f1f06e1ab9b02f8fb3.zip
dev-python/identify: Bump to 2.5.30
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/identify')
-rw-r--r--dev-python/identify/Manifest1
-rw-r--r--dev-python/identify/identify-2.5.30.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/identify/Manifest b/dev-python/identify/Manifest
index 7be8e51bc106..c24d0c85688e 100644
--- a/dev-python/identify/Manifest
+++ b/dev-python/identify/Manifest
@@ -1 +1,2 @@
DIST identify-2.5.29.gh.tar.gz 101599 BLAKE2B 57e444c99062c10334ac7d0642c47c9f706dc31447db6b5eff0997f5d6113723f6bd06d5dabf0ebdbf0dbc17d33b716e68864902ffe1c92638052458a53affa8 SHA512 f7feab8872bef0c8c3c07429f41d73455ae9f317ed5e974349af04ca0b459677c65ead47e85e58753f53f592b2a0363844496c43d7ffe25e2228f5e11b411b4d
+DIST identify-2.5.30.gh.tar.gz 101610 BLAKE2B d5f277316d58a1fbd78a193c357656e5f16e66f4a737a8b415570afc6bddedf130a4557c486696fbe0ed86542598122f65f0f14536430a59f4e970fa2ab78f75 SHA512 cbae5ca100f0e09fccd1b311243b1bc090ac63bc19fcdc57241bbdfe07920e4d0041d7ac69ab37ede38628c6f3ad8e7b34f698576f4a1188ae94dc6e32ec968a
diff --git a/dev-python/identify/identify-2.5.30.ebuild b/dev-python/identify/identify-2.5.30.ebuild
new file mode 100644
index 000000000000..906b58d7a709
--- /dev/null
+++ b/dev-python/identify/identify-2.5.30.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="File identification library for Python"
+HOMEPAGE="
+ https://github.com/pre-commit/identify/
+ https://pypi.org/project/identify/
+"
+SRC_URI="
+ https://github.com/pre-commit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/ukkonen[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest