summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-03-11 14:13:32 +0100
committerLouis Sautier <sbraz@gentoo.org>2020-03-11 18:12:45 +0100
commit8ff930d979fecf14b7fbae5c8cff16f354d1dd4c (patch)
tree965c792eb05a060e3e30991d1630606be383e237 /dev-python/httpauth
parentgnome-extra/gnome-shell-extension-desktop-icons: Bump to 19.10.2 (diff)
downloadgentoo-8ff930d979fecf14b7fbae5c8cff16f354d1dd4c.tar.gz
gentoo-8ff930d979fecf14b7fbae5c8cff16f354d1dd4c.tar.bz2
gentoo-8ff930d979fecf14b7fbae5c8cff16f354d1dd4c.zip
dev-python/httpauth: add Py3.8 support, fix deps
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/httpauth')
-rw-r--r--dev-python/httpauth/httpauth-0.3.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/dev-python/httpauth/httpauth-0.3.ebuild b/dev-python/httpauth/httpauth-0.3.ebuild
index ec763d1968cc..5bff2d382521 100644
--- a/dev-python/httpauth/httpauth-0.3.ebuild
+++ b/dev-python/httpauth/httpauth-0.3.ebuild
@@ -3,7 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
@@ -14,14 +15,5 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-python_test() {
- nosetests -v tests.py || die "tests failed with ${EPYTHON}"
-}
+distutils_enable_tests nose