summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2020-05-14 09:42:49 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-14 09:42:49 -0700
commit0bc21ec372d1ed9f1047dcd8b61d5d38ff967543 (patch)
tree9de5e07d645f05354183f0dd065e75d29124ced9 /dev-python/google-api-python-client/google-api-python-client-1.8.3-r1.ebuild
parentdev-python/sphinx-issues: Tested on py3.8 (diff)
downloadgentoo-0bc21ec372d1ed9f1047dcd8b61d5d38ff967543.tar.gz
gentoo-0bc21ec372d1ed9f1047dcd8b61d5d38ff967543.tar.bz2
gentoo-0bc21ec372d1ed9f1047dcd8b61d5d38ff967543.zip
dev-python/google-api-python-client-1.8.3-r1: revbump, add test dep
Last version bump was missing a new test dep on oauth2client, reported by sam_c on IRC Reported-by: sam_c Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client/google-api-python-client-1.8.3-r1.ebuild')
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-1.8.3-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-1.8.3-r1.ebuild b/dev-python/google-api-python-client/google-api-python-client-1.8.3-r1.ebuild
new file mode 100644
index 000000000000..7a7ab2ced465
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-1.8.3-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/google/google-api-python-client"
+SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.9.2[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/google-api-core[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.0.3[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-4[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ <dev-python/six-2[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/google-auth-httplib2[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/google-api-python-client-1.8.3-tests.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "tests fail with ${EPYTHON}"
+}