summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-16 10:25:19 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-16 10:54:39 +0100
commite6c602792f645c879a1188096209adadad16b260 (patch)
tree3b1414bf42cfd49b335c3c272d2fa94caacecb97 /dev-python/flask-security
parentdev-python/pymongo: Bump to 4.0.2 (diff)
downloadgentoo-e6c602792f645c879a1188096209adadad16b260.tar.gz
gentoo-e6c602792f645c879a1188096209adadad16b260.tar.bz2
gentoo-e6c602792f645c879a1188096209adadad16b260.zip
dev-python/flask-security: Bump to 4.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-security')
-rw-r--r--dev-python/flask-security/Manifest1
-rw-r--r--dev-python/flask-security/flask-security-4.1.3.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/flask-security/Manifest b/dev-python/flask-security/Manifest
index 5350bc4d66cb..dc09a8a88117 100644
--- a/dev-python/flask-security/Manifest
+++ b/dev-python/flask-security/Manifest
@@ -1,2 +1,3 @@
DIST flask-security-3.4.5.gh.tar.gz 348928 BLAKE2B 9890227e9775c4a28fc364affb0bf767407463d514f6dc3cd359dd8a026e8325d943a547f294f6363a276f9e7d97336c526dd45f4549c7cfaff2d6ef9ef0316a SHA512 f9ac7f46b2e1ab7dbb44ba925b01e16304e8f8d6d5d56f4e558d07b80dfffa59f04c2597e17c00a7d7ae11be3a97c78ccf8d79993b7451be4a7f75f85bc89f6f
DIST flask-security-4.1.2.gh.tar.gz 408120 BLAKE2B a4ec9b0a58368b9c84ee2d5b8b7404adf4a985067fca79e574726efc7cd78f9b713360c7d9d53a29ef6dd2ec7d23b64e50893fd75259a00c2b549a4b2a821936 SHA512 8fd3a0561ccc8dd815483fc8d2863a13fa83dea4cf308972778f99c29f0f7496f95cfac483f1a4cf2f77cd2a728eb09a5f8e8b4147d2749aa0b75f98b752ba36
+DIST flask-security-4.1.3.gh.tar.gz 408609 BLAKE2B ef4b270d62de75fdcf51d1247960df85deca1699fdbfb73592a5711f9bb56f71a2f2de12a8d8c0eccdaccfef11a578cf9bd9abbf52bdacfe4bfc10f9adda0acc SHA512 92a0e7fce95eb4eb04baa9a11ee88ab3b8e88952aa6300bf8245cecfcc90657c83bbe93e1c3b19d62642a346b30f5912dd424e59a81023637f3183a61e8cf91c
diff --git a/dev-python/flask-security/flask-security-4.1.3.ebuild b/dev-python/flask-security/flask-security-4.1.3.ebuild
new file mode 100644
index 000000000000..9e3dec883189
--- /dev/null
+++ b/dev-python/flask-security/flask-security-4.1.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple security for Flask apps"
+HOMEPAGE="
+ https://github.com/Flask-Middleware/flask-security/
+ https://pypi.org/project/Flask-Security-Too/"
+SRC_URI="
+ https://github.com/Flask-Middleware/flask-security/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/bleach-3.3.1[${PYTHON_USEDEP}]
+ >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
+ dev-python/cachetools[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-babelex-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-login-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-principal-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-wtf-0.14.3[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.7.2[${PYTHON_USEDEP}]
+ >=dev-python/python-email-validator-1.1.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/argon2-cffi-19.1.0[${PYTHON_USEDEP}]
+ >=dev-python/bcrypt-3.1.5[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-mail-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-sqlalchemy-2.3[${PYTHON_USEDEP}]
+ >=dev-python/mongomock-3.19.0[${PYTHON_USEDEP}]
+ >=dev-python/peewee-3.11.2[${PYTHON_USEDEP}]
+ >=dev-python/phonenumbers-8.11.1[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.8.4:2[${PYTHON_USEDEP}]
+ >=dev-python/pymysql-0.9.3[${PYTHON_USEDEP}]
+ >=dev-python/pyqrcode-1.2[${PYTHON_USEDEP}]
+ >=dev-python/zxcvbn-4.4.28[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/pony-0.7.11[${PYTHON_USEDEP}]
+ ' python3_8 python3_9)
+ amd64? ( >=dev-python/flask-mongoengine-0.9.5[${PYTHON_USEDEP}] )
+ arm64? ( >=dev-python/flask-mongoengine-0.9.5[${PYTHON_USEDEP}] )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's@--cache-clear@-p no:httpbin@' pytest.ini || die
+ distutils-r1_src_prepare
+}
+
+python_configure_all() {
+ esetup.py compile_catalog
+}