summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-01 16:18:13 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-05 06:10:35 +0100
commitb0301eada4ee37b58626f30760ab55309673c2a8 (patch)
tree735ce52f5b76eea8885551e26d10cb73711dc897 /dev-python/ensurepip-pip
parentdev-python/markups: Use pypi.eclass (diff)
downloadgentoo-b0301eada4ee37b58626f30760ab55309673c2a8.tar.gz
gentoo-b0301eada4ee37b58626f30760ab55309673c2a8.tar.bz2
gentoo-b0301eada4ee37b58626f30760ab55309673c2a8.zip
dev-python/ensurepip-pip: Use pypi.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ensurepip-pip')
-rw-r--r--dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild b/dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild
index 971c00d30abe..8a4b916f03bd 100644
--- a/dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild
+++ b/dev-python/ensurepip-pip/ensurepip-pip-23.0.ebuild
@@ -3,14 +3,11 @@
EAPI=8
-MY_PN=${PN#ensurepip-}
-WHL=${MY_PN}-${PV}-py3-none-any.whl
+inherit pypi
DESCRIPTION="Shared pip wheel for ensurepip Python module"
HOMEPAGE="https://pypi.org/project/pip/"
-SRC_URI="
- https://files.pythonhosted.org/packages/py3/${MY_PN::1}/${MY_PN}/${WHL}
-"
+SRC_URI="$(pypi_wheel_url "${PN#ensurepip-}")"
S=${DISTDIR}
LICENSE="Apache-2.0 BSD BSD-2 ISC LGPL-2.1+ MIT MPL-2.0 PSF-2"
@@ -23,5 +20,5 @@ RDEPEND="
src_install() {
insinto /usr/lib/python/ensurepip
- doins "${WHL}"
+ doins "${A}"
}