summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-02 07:32:36 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-02 08:05:34 +0200
commit0e42ede7a72e8d6e8546dd156ce88ae0762e0627 (patch)
treec1adadeb4f93c101c70f0e2eefabead4951d9cd2 /dev-python/chardet
parentdev-python/cryptography: Bump to 41.0.3 (diff)
downloadgentoo-0e42ede7a72e8d6e8546dd156ce88ae0762e0627.tar.gz
gentoo-0e42ede7a72e8d6e8546dd156ce88ae0762e0627.tar.bz2
gentoo-0e42ede7a72e8d6e8546dd156ce88ae0762e0627.zip
dev-python/chardet: Bump to 5.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/chardet')
-rw-r--r--dev-python/chardet/Manifest1
-rw-r--r--dev-python/chardet/chardet-5.2.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/chardet/Manifest b/dev-python/chardet/Manifest
index b84aae600933..48f23e16d5c4 100644
--- a/dev-python/chardet/Manifest
+++ b/dev-python/chardet/Manifest
@@ -1 +1,2 @@
DIST chardet-5.1.0.gh.tar.gz 2067545 BLAKE2B 92fd916884ecd562a3ad51c58848430d1b5acad0841a410f316be4346e4c2198e5c27ce5af8639a06d6472ece6807dd2618f4a50760e77925c994d13619d290e SHA512 531888329979d229f3e966a428d14feb4612df5b71e3dff3ee3358ecbc964af95370e4c03aacecea0941d11840a16b2b12814ea8af977ff81a5abbec41d983cd
+DIST chardet-5.2.0.gh.tar.gz 2067352 BLAKE2B e9b960bad6ad7e9933f0fcd6e445bdefdd795f6150bf96e59714bfb9bd0cf63adeba80b608a1890f07be81565c160977fa96140984720407d93b0919eeb71a8b SHA512 3c6614882b251e53322eb75fdd01c3d7664c5f611bbfc1480fa10d57f02906b4be42a8b7ff4d3bdc00465340a2ca46b31f1f0d25f64d4f69df0ac0876e71e87f
diff --git a/dev-python/chardet/chardet-5.2.0.ebuild b/dev-python/chardet/chardet-5.2.0.ebuild
new file mode 100644
index 000000000000..b8ee0eb33666
--- /dev/null
+++ b/dev-python/chardet/chardet-5.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Universal encoding detector"
+HOMEPAGE="
+ https://github.com/chardet/chardet/
+ https://pypi.org/project/chardet/
+"
+SRC_URI="
+ https://github.com/chardet/chardet/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # super flaky test
+ # https://github.com/chardet/chardet/issues/256
+ test.py::test_detect_all_and_detect_one_should_agree
+)