summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-22 05:07:26 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-22 05:07:26 +0200
commita873a6ac6f61874aca035724534164b3140a58d2 (patch)
tree4e7d3700d9e678bee2a1f0010391399f76e4db6d /dev-python/boto3
parentdev-python/botocore: Bump to 1.31.31 (diff)
downloadgentoo-a873a6ac6f61874aca035724534164b3140a58d2.tar.gz
gentoo-a873a6ac6f61874aca035724534164b3140a58d2.tar.bz2
gentoo-a873a6ac6f61874aca035724534164b3140a58d2.zip
dev-python/boto3: Bump to 1.28.31
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.28.31.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 8674d19f011e..1441d97b0546 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -6,3 +6,4 @@ DIST boto3-1.28.27.gh.tar.gz 689084 BLAKE2B 5e6c824aedd92f429a5e932a8839d2f85562
DIST boto3-1.28.28.gh.tar.gz 689176 BLAKE2B 21a951604fb2c5f6435d6c27dfbab5a4d16071fc9a4260374529902dd3715bd9ae8b724e75ad1c550696b8f781b54fc31f8ede6e489f950c263be44fbb387dcf SHA512 3b6a736de618ef094203c04b8c5408b20d3ca006514266423c20d3716269bad70532a90fec66a2a8bc168830ceb128b4dd314d23132656ab8c45d19bdaca345f
DIST boto3-1.28.29.gh.tar.gz 689353 BLAKE2B 6d8816cd1857b2c9b968730488ccc6822a721e65275a247284a85702f16462a7075e72a53d575ab5ecf450666a80b7d750503a315c5205b09a5850ff37cae684 SHA512 624060c702af72ab083f2bbbf9d406485db2df953f3fde1f9c32bfeff4c9bd4ef1498052c8cb7356ab1aec51132cb77f4af34da15af0aa92da67724646643cd8
DIST boto3-1.28.30.gh.tar.gz 689629 BLAKE2B 03081369f995ae470717c32ffd0e80c1bac6677467cd4af57b4a7e19d5c0249c825a2db787d5e6d7319b1af808936043e07b1d5ff13eb413125478710a18a416 SHA512 ace77ea7898cd7baa47c256affe553bbec2410f0143caf3b06311d66c306dfe2d4ce8b47820d6c8ceb3f4a7a195d94610b46db2bb0ed2e3716dcee99b8841468
+DIST boto3-1.28.31.gh.tar.gz 690064 BLAKE2B 409dcdb3c4a0ee2bb32d8a68ba2779d347b0686076c9bc922320b370def9faa6cde964279d8fb2d885f547299e1358c05db80688fdf953ddf70030eb282ebed9 SHA512 6a1de5568c5663a9f37ae991ae072fbfa7fcafbfa5786bfcd4335c6dcdb1eadee8050ead64251cc687b8f954b6d3a79fd3bef0b1fedd4cd4fcb2d63f405a0323
diff --git a/dev-python/boto3/boto3-1.28.31.ebuild b/dev-python/boto3/boto3-1.28.31.ebuild
new file mode 100644
index 000000000000..d155ad52d110
--- /dev/null
+++ b/dev-python/boto3/boto3-1.28.31.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}