summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-17 08:03:49 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-17 08:50:59 +0200
commit03feb26281017528f75796cd13af7a1b38187ecf (patch)
treee1ff22d524e7f9c4c56c278156c9f764df8c8277 /dev-python/boto3
parentdev-python/botocore: Bump to 1.31.28 (diff)
downloadgentoo-03feb26281017528f75796cd13af7a1b38187ecf.tar.gz
gentoo-03feb26281017528f75796cd13af7a1b38187ecf.tar.bz2
gentoo-03feb26281017528f75796cd13af7a1b38187ecf.zip
dev-python/boto3: Bump to 1.28.28
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.28.28.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 11a20209dfdb..b780c496e85e 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.28.20.gh.tar.gz 684832 BLAKE2B dc8dee3e001e26fa5e9f1355ef40cb03a860
DIST boto3-1.28.25.gh.tar.gz 687791 BLAKE2B 641dacd5076e51e64991c0bb97fda6f5b8d705b253ab902a5598daf23eca65ad586348f38e6dce0dfd90526a49ff56320dc99972d375e61d5fab3692f5948674 SHA512 2e47027c035338a9d70027b32c93db04ac859a8cfe6c9f962df33c1139df5ba1562e9e0bb32670825a93c29fa2b231779221c6b54c5b2bb498c5e19667763306
DIST boto3-1.28.26.gh.tar.gz 687954 BLAKE2B 04e87223eac560264ef55c80d5d258b028b9fb99a52a9ee03feda818909aafb43dfe16e887593e3dfb51525c78c8cd92a1e6e97b96136795b51a69839bb84580 SHA512 1cf5c2cc795a7712abff17aa075d30054973bf2cb583bdf4ad5e3057309cc76dd6a50b2ad806cb720c7528b4e3087f6b84b5b7a8d3d365df14e582e626168768
DIST boto3-1.28.27.gh.tar.gz 689084 BLAKE2B 5e6c824aedd92f429a5e932a8839d2f855624d4e821a3b9e8e434d6d47c9dfbc44fd5f93df451fe19be089513dad56f5291186f734b696914ce867f5e4a436e2 SHA512 6233f4da3fcb84b24bdc5c3aa3914de0cdd31212b1927eafb82972a4c751556699cd653be014d7d838836a92a5a35368d6874e19f6fb04a730606868a656c53e
+DIST boto3-1.28.28.gh.tar.gz 689176 BLAKE2B 21a951604fb2c5f6435d6c27dfbab5a4d16071fc9a4260374529902dd3715bd9ae8b724e75ad1c550696b8f781b54fc31f8ede6e489f950c263be44fbb387dcf SHA512 3b6a736de618ef094203c04b8c5408b20d3ca006514266423c20d3716269bad70532a90fec66a2a8bc168830ceb128b4dd314d23132656ab8c45d19bdaca345f
diff --git a/dev-python/boto3/boto3-1.28.28.ebuild b/dev-python/boto3/boto3-1.28.28.ebuild
new file mode 100644
index 000000000000..d155ad52d110
--- /dev/null
+++ b/dev-python/boto3/boto3-1.28.28.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}