summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-28 11:25:12 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-28 11:46:58 +0200
commit8b0d3584a731d0f416ca5a019ec99935d0f3ce7a (patch)
tree49745ec4329c7816f98eeb3a712901c200299241 /dev-python/beniget
parentdev-python/gast: pep517, enable py3.11 (diff)
downloadgentoo-8b0d3584a731d0f416ca5a019ec99935d0f3ce7a.tar.gz
gentoo-8b0d3584a731d0f416ca5a019ec99935d0f3ce7a.tar.bz2
gentoo-8b0d3584a731d0f416ca5a019ec99935d0f3ce7a.zip
dev-python/beniget: update EAPI 7 -> 8, enable py3.11, pep517
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/beniget')
-rw-r--r--dev-python/beniget/beniget-0.4.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/beniget/beniget-0.4.1-r1.ebuild b/dev-python/beniget/beniget-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..57cdfd31f83d
--- /dev/null
+++ b/dev-python/beniget/beniget-0.4.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Extract semantic information about static Python code"
+HOMEPAGE="
+ https://pypi.org/project/beniget/
+ https://github.com/serge-sans-paille/beniget/"
+SRC_URI="
+ https://github.com/serge-sans-paille/beniget/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="=dev-python/gast-0.5*[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py